Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] mpirun: symbol lookup error:/usr/local/lib/openmpi/mca_plm_lsf.so: undefined symbol: ls b_init
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2009-04-10 12:58:25


On Apr 1, 2009, at 12:00 PM, Alessandro Surace wrote:

> Hi guys, I try to repost my question...
> I've a problem with the last stable build and the last nightly
> snapshot.
>
> When I run a job directly with mpirun no problem.
> If I try to submit it with lsf:
> bsub -a openmpi -m grid01 mpirun.lsf /mnt/ewd/mpi/fibonacci/
> fibonacci_mpi
>
> I get the follow error:
> mpirun: symbol lookup error: /usr/local/lib/openmpi/mca_plm_lsf.so:
> undefined symbol: lsb_init
> Job /opt/lsf/7.0/linux2.6-glibc2.3-x86/bin/openmpi_wrapper /mnt/ewd/
> mpi/fibonacci/fibonacci_mpi

Sorry for the delay in replying -- travel always gets me waaay behind
on my INBOX...

What is mpirun.lsh and the openmpi_wrapper executable?

> I've verified that the lsb_init symbol is present in the library:
> [root_at_grid01 lib]# strings libbat.* |grep lsb_init

Can you try "nm libbat.so | grep lsb_init"?

> No problem with version 1.2.9.

FWIW, OMPI v1.2.9 did not have embedded LSF support.

I wonder if you're somehow having two different versions of OMPI mixed
up, or perhaps if two different elements are trying to use LSF support
(e.g., this openmpi_wrapper thingy and Open MPI's mpirun itself...?).

-- 
Jeff Squyres
Cisco Systems