Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] I encoutered Bus Error while running openMPI on IB.
From: Tsung Han Shie (icbm0926_at_[hidden])
Date: 2009-04-09 12:53:53


Hi all,

I've build an openmpi-1.3.1 binary on a machine with openSUSE 10.2, gcc
4.1.2¡C
The cluster I tried to run jobs on uses Silverstorm infiniband system and
uses ibverbs as its IB driver. The configure parameters listed below:

./configure --prefix=/d/thshie/vp31/openmpi/
--with-openib=/usr/local/ibverbs1.1.1/ --with-tm=/usr/local/torque2.1.8/
CFLAGS=-m64 CXXFLAGS=-m64 FFLAGS=-m64 FCFLAGS=-m64 --disable-shared
--enable-static

The cluster system uses "rsh" as the process lauch system. While I ran a job
with "<mpirun path> --mca pls_rsh_agent rsh -np 128 -machinefile machines
-nolocal <job command>". I shows following messages:
====================================================
A deprecated MCA parameter value was specified in the environment or
on the command line. Deprecated MCA parameters should be avoided;
they may disappear in future releases.

  Deprecated parameter: pls_rsh_agent
--------------------------------------------------------------------------
Bus error
====================================================
I've looked into maling lists. But the contents seemsto be related to the
developments of openMPI. Can anyone gives me some guides about how this
would happen and how do I fixed it?