Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] mpirun: symbol lookup error: /usr/local/lib/openmpi/mca_plm_lsf.so: undefined symbol: ls b_init
From: Prentice Bisbal (prentice_at_[hidden])
Date: 2009-04-06 16:02:57


Alessandro Surace wrote:
> Hi guys, I try to repost my question...
> I've a problem with the last stable build and the last nightly snapshot.
>
> When I run a job directly with mpirun no problem.
> If I try to submit it with lsf:
> bsub -a openmpi -m grid01 mpirun.lsf /mnt/ewd/mpi/fibonacci/fibonacci_mpi
>
> I get the follow error:
> mpirun: symbol lookup error: /usr/local/lib/openmpi/mca_plm_lsf.so:
> undefined symbol: lsb_init
> Job /opt/lsf/7.0/linux2.6-glibc2.3-x86/bin/openmpi_wrapper
> /mnt/ewd/mpi/fibonacci/fibonacci_mpi
>
> I've verified that the lsb_init symbol is present in the library:
> [root_at_grid01 lib]# strings libbat.* |grep lsb_init
> lsb_init
> sch_lsb_init
> lsb_init()
> lsb_init
> sch_lsb_init
> sch_lsb_init
> sch_lsb_init
> sch_lsb_init
> lsb_init()
> sch_lsb_init
>

Can you verify that LSF is passing your evironment along correctly? It
looks like your LD_LIBRARY_PATH is set in your login environment, but
not the environment that the LSF job runs in

You can check this by submitting a jog that executes just the command
'printenv'. Compare the output to what you get when you type 'printenv'
on the command. Compare the values for LD_LIBRARY_PATH, in particular.

If that looks okay, then try running a job that just executes

ldd /mnt/ewd/mpi/fibonacci/fibonacci_mpi

This will show you any libraries that ld can't find in the LSF run-time
environment.

-- 
Prentice