Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] Problems Compiling OpenMPI with Sun Studio 12
From: Terry Dontje (Terry.Dontje_at_[hidden])
Date: 2009-04-03 11:16:17


Which version of the Sun Studio compilers are you using also which
version of OMPI are you trying to build. I am successful with building
OMPI with the Sun Studio Express release 200811 on Linux systems if I
don't use the C++ compiler. Prior releases we did suffer from some
issues. A "cc -V" will give you the exact version of Sun Studio you are
using.

I noticed in your configure line below you don't have a space between
"--enable-shared" and "--enable-orterun-prefix-by-default ". Not sure
this has anything to do with your problem but it might cause unintended
results.

--td

> Date: Fri, 03 Apr 2009 10:58:00 -0300 From: "Segovia, Andrea"
> <SegoviaA_at_[hidden]> Subject: [OMPI users] Problems Compiling
> OpenMPI with Sun Studio 12 compilers on RHEL 5 To: users_at_[hidden]
> Message-ID:
> <AA70C242FCB6FD4286597BD88BCB3F3F0C4683A0_at_[hidden]>
> Content-Type: text/plain; charset="iso-8859-1"
>> > Hello,
>> >
>> > I am trying to compile OpenMPI on a Red Hat Enterprise Linux 5 platform with the Sun Studio 12 compiler suite. (I currently have the Red Hat-bundled OpenMPI w/GNU compilers running).
>> >
>> > I have already encountered and addressed the problem of the C++ compiler not working in 64 bit mode with the Red Hat-bundled GNU ld by not including sunCC in the OpenMPI compilation, since we do not need C++ support.
>> >
>> > However, I have encountered another problem when attempting to compile (at the "make all" stage):
>> >
>> > asm/.libs/libasm.a(atomic-asm.o): In function `opal_atomic_mb':
>> > (.text+0x0): multiple definition of `opal_atomic_mb'
>> > asm/.libs/libasm.a(asm.o):asm.c:(.text+0x0): first defined here
>> > asm/.libs/libasm.a(atomic-asm.o): In function `opal_atomic_rmb':
>> > (.text+0x6): multiple definition of `opal_atomic_rmb'
>> > asm/.libs/libasm.a(asm.o):asm.c:(.text+0x10): first defined here
>> >
>> > ..(small excerpt)
>> >
>> > Sun has published bug information about a similar error here: http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6567405 but I don't know if it applies. Besides, their suggested fix is to change the source code, something I would be extremely reluctant to do.
>> >
>> > The OpenMPI users mailing list has at one reference to this problem here: http://www.open-mpi.org/community/lists/users/2008/10/6908.php but I have not been able to find a solution.
>> >
>> > I am enclosing a gzipped tar file with the configure output, config.log and make output as suggested.
>> >
>>
>>> > > <<ompi_output.tar.gz>>
>>>
>> >
>> > I am using the following options to configure (based on the recommendations on the OpenMPI FAQ here: http://www.open-mpi.org/faq/?category=building#build-sun-compilers )This section references the errors found above but does not provide a work-around.
>> >
>>
> $ ./configure CC=suncc F77=sunf77 FC=sunf90 --prefix=/export/home/segovia/RunTime_Environ/ --enable-heterogeneous --enable-shared--enable-orterun-prefix-by-default --enable-mpi-f90 --with-mpi-f90-size=small --disable-mpi-threads --disable-progress-threads --disable-debug --with-openib --without-udapl --disable-openib-ibcm
>
>
>> > Has anyone been successful with this build? What options/workarounds were necessary to compile?
>> >
>> > Any help or information would be greatly appreciated.
>> >
>> > Andrea Segovia
>> > IM&TS, Data Centre Services, East / GIST, Services du Centre de traitement des donn?es de l' est
>> > Fisheries and Oceans Canada | P?ches et Oc?ans Canada
>>