Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] Issues on install 1.3.1
From: Francesco Pietra (chiendarret_at_[hidden])
Date: 2009-04-02 07:21:30


Hi:
With debian linux amd64 lenny I tried to install openmpi-1.3.1 instead
of using the executables openmpi-1.2.6 of previous disks. I configured
as for 1.2.6 (wrong ?)

CC=/opt/intel/cce/10.1.015/bin/icc CXX=opt/intel/cce/10.1.015/bin/icpc
F77=/opt/intel/fce/10.1.015/bin/ifort
FC=/opt/intel/fce/10.1.015/bin/ifort --with-libnuma=/usr/lib

getting:

checking whether using GNU C++ compiler .. yes

dependency style icpc ... gcc3

checking how to run C++ preprocessor ... /lib/cpp

checking for compiler vendor ... intel

cheching if C++ compiler works .. NO

it is not clear to me to which compiler NO refers: gcc or intel? I
would also appreciate very much a direction how to chech gcc and intel
C++ independently.

I checked that:

which ifort
/opt/intel/fce/10.1.015/bin/ifort

in my .bashrc:

. /opt/intel/fce/10.1.015/bin/ifortvars.sh (and iccvars.sh)

thanks
francesco pietra