Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: [OMPI users] mpirun: symbol lookup error: /usr/local/lib/openmpi/mca_plm_lsf.so: undefined symbol: ls b_init
From: Alessandro Surace (zioalex_at_[hidden])
Date: 2009-04-01 12:00:04


Hi guys, I try to repost my question...
I've a problem with the last stable build and the last nightly snapshot.

When I run a job directly with mpirun no problem.
If I try to submit it with lsf:
bsub -a openmpi -m grid01 mpirun.lsf /mnt/ewd/mpi/fibonacci/fibonacci_mpi

I get the follow error:
mpirun: symbol lookup error: /usr/local/lib/openmpi/mca_plm_lsf.so:
undefined symbol: lsb_init
Job /opt/lsf/7.0/linux2.6-glibc2.3-x86/bin/openmpi_wrapper
/mnt/ewd/mpi/fibonacci/fibonacci_mpi

I've verified that the lsb_init symbol is present in the library:
[root_at_grid01 lib]# strings libbat.* |grep lsb_init
lsb_init
sch_lsb_init
lsb_init()
lsb_init
sch_lsb_init
sch_lsb_init
sch_lsb_init
sch_lsb_init
lsb_init()
sch_lsb_init

My lsf version is:
Platform LSF 7.0.4.115872, Sep 24 2008
Copyright 1992-2008 Platform Computing Corporation

  binary type: linux2.6-glibc2.3-x86

No problem with version 1.2.9.

In attach the info about Open mpi.

Thankx
Alex