Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Linux opteron infiniband sunstudio configure, problem
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2009-03-31 16:59:00


My goal in having you try that statement in a standalone shell script
wasn't the success or failure of the uname command -- but rather to
figure out if something in that statement itself was causing the
syntax error.

Apparently it is not. There's an errant character elsewhere that is
causing the problem. FWIW, you should be able to run ./config/
config.guess by itself and get a single line of output with no errors
-- so you don't even have to test this in the larger context of Open
MPI's configure process. As you showed in an earlier mail, even that
doesn't work.

We get config.guess from git.savannah.gnu.org when we make OMPI
tarballs. FWIW, here's the md5 and sha1sums from the config.guess
that I got from a 1.3.1 tarball:

13:57] svbu-mpi:/home/jsquyres/openmpi-1.3.1 % md5sum config/
config.guess
6384bbc496ef6e69328a9a428c623cc5 config/config.guess
[13:58] svbu-mpi:/home/jsquyres/openmpi-1.3.1 % sha1sum config/
config.guess
199adb16fc94e6cf62912be5fbb69a77214b33e5 config/config.guess

I would be pretty surprised if yours don't match. If they don't
there's some larger issue going on (e.g., filesystem corruption?) that
would also be pretty surprising.

On Mar 31, 2009, at 4:36 PM, Kevin McManus wrote:

> On Tue, Mar 31, 2009 at 10:11:17PM +0200, Bogdan Costescu wrote:
> > On Tue, 31 Mar 2009, Bogdan Costescu wrote:
> >
> > >'uname -X' is valid on Solaris, but not on Linux.
> >
> > Not good to reply to oneself, but I've looked at the archives and
> > realized that 'uname -X' comes from a message of the OP. My guess is
> > that the same source directory was used to build for Solaris
> > previously (maybe on shared NFS ?) and some state is being picked
> by a
> > new ./configure run who then decides to treat the system as Solaris.
> > So unpacking the archive again and starting building from scratch
> > might be a good idea...
>
> Hmmm...
>
> The machine is isolated, no nfs but there is a SunStudio compiler
> suite
> in my path before /bin and /user/bin.
>
> A bit worrying if this is the answer but will re-arrange paths and try
> unpacking again - anything is worth a try :-)
>
>
> k.mcmanus_at_[hidden] - http://staffweb.cms.gre.ac.uk/~k.mcmanus
> --------------------------------------------------------------
> Dr Kevin McManus Queen Mary 413
> School of Computing & Mathematical Sciences,
> University of Greenwich,
> Old Royal Naval College,
> Park Row, Greenwich, Tel +44 (0)208 331 8719
> London, SE10 9LS Fax +44 (0)208 331 8665
> --------------------------------------------------------------
>
> University of Greenwich, a charity and company limited by
> guarantee, registered in England (reg no. 986729)
> Registered Office: Old Royal Naval College
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
Cisco Systems