Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Linux opteron infiniband sunstudio configure, problem
From: Terry Dontje (Terry.Dontje_at_[hidden])
Date: 2009-03-30 13:21:41


I also was unable to reproduce the configure error with the latest 1.3
tarball. I was on a SLES distribution. What distribution are you on
and can you possibly try and configure using gcc instead of Sun Studio?
I have a feeling this issue is a larger configure issue and not Sun
Studio specific.

thanks,

--td
> Date: Mon, 30 Mar 2009 16:02:11 +0100
> From: Kevin McManus <k.mcmanus_at_[hidden]>
> Subject: Re: [OMPI users] Linux opteron infiniband sunstudio configure
> problem
> To: Open MPI Users <users_at_[hidden]>
> Message-ID: <20090330150211.GO13818_at_[hidden]>
> Content-Type: text/plain; charset=us-ascii
>
> On Mon, Mar 30, 2009 at 09:04:26AM -0500, Ethan Mallove wrote:
>
>> > On Thu, Mar/26/2009 04:52:28PM, Kevin McManus wrote:
>>
>>> > >
>>> > > Hi All,
>>> > >
>>> > > As a complete beginner (to OpenMPI) I am attempting to build on
>>> > > a Linux opteron infiniband platform using SunStudio compilers.
>>> > >
>>> > > My build script looks like...
>>> > >
>>> > > #!/bin/sh
>>> > >
>>> > > ../configure x86_64 \
>>> > > CC=cc CXX=CC F77=f77 FC=f90 \
>>> > > CFLAGS=-m64 CXXFLAGS=-m64 FFLAGS=-m64 FCFLAGS=-m64 \
>>> > > --enable-static \
>>> > > --enable-orterun-prefix-by-default \
>>> > > --enable-mpi-f90 \
>>> > > --enable-mpi-threads \
>>> > > --with-psm
>>>
>> >
>> > We configure with --disable-mpi-threads, and have not tested
>> > --with-psm and --with-static. Do you provide --with-psm a DIR
>> > argument? "configure --help" shows:
>>
>
> configure: error: unrecognized option: --diable-mpi-threads
> Try `../configure --help' for more information.
>
>
>> >
>> > ...
>> > --with-psm(=DIR) Build PSM (QLogic InfiniPath PSM) support, searching
>> > for libraries in DIR
>> > --with-psm-libdir=DIR Search for PSM (QLogic InfiniPath PSM) libraries in
>> > DIR
>>
>
> Not sure how to phrase the --with-psm(=DIR)
>
> I can find psm libs at...
>
> /usr/lib/libpsm_infinipath.so.1.0
> /usr/lib/libpsm_infinipath.so.1
> /usr/lib64/libpsm_infinipath.so.1.0
> /usr/lib64/libpsm_infinipath.so.1
>
> so maybe I should use
> --with-psm
> --with-psm-libdir=/usr/lib64
> but even if I remove --with-psm I hit the same problem with the MCA bucket
>
>
>
>> > I will try to reproduce the problem.
>>
>
> Thanks for your help :-)
>
>
>> >