Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Linux opteron infiniband sunstudio configure problem
From: Ethan Mallove (ethan.mallove_at_[hidden])
Date: 2009-03-30 11:57:21


On Mon, Mar/30/2009 09:04:26AM, Ethan Mallove wrote:
> On Thu, Mar/26/2009 04:52:28PM, Kevin McManus wrote:
> >
> > Hi All,
> >
> > As a complete beginner (to OpenMPI) I am attempting to build on
> > a Linux opteron infiniband platform using SunStudio compilers.
> >
> > My build script looks like...
> >
> > #!/bin/sh
> >
> > ../configure x86_64 \
> > CC=cc CXX=CC F77=f77 FC=f90 \
> > CFLAGS=-m64 CXXFLAGS=-m64 FFLAGS=-m64 FCFLAGS=-m64 \
> > --enable-static \
> > --enable-orterun-prefix-by-default \
> > --enable-mpi-f90 \
> > --enable-mpi-threads \
> > --with-psm
>
> We configure with --disable-mpi-threads, and have not tested
> --with-psm and --with-static. Do you provide --with-psm a DIR
> argument? "configure --help" shows:
>
> ...
> --with-psm(=DIR) Build PSM (QLogic InfiniPath PSM) support, searching
> for libraries in DIR
> --with-psm-libdir=DIR Search for PSM (QLogic InfiniPath PSM) libraries in
> DIR
> ...
>
> I will try to reproduce the problem.

I am not able to reproduce this with openmpi-1.3.2a1r20880.tar.gz.

  $ uname -a
  Linux ... 2.6.16.46-0.12-smp #1 SMP Thu May 17 14:00:09 UTC 2007 x86_64 x86_64 x86_64 GNU/Linux
  $ cc -V
  cc: Sun C 5.9 Linux_i386 Patch 124871-01 2007/07/31

-Ethan

>
> -Ethan
>
>
> >
> > Not sure why I need to put x86_64 as the first argument, just a lucky
> > guess after...
> >
> > configure: error: cannot guess build type; you must specify one
> >
> > ...but I hit another problem...
> >
> > --- MCA component allocator:basic (no configuration)
> > checking for MCA component allocator:basic compile mode... static
> > checking if MCA component allocator:basic can compile... yes
> >
> > --- MCA component allocator:bucket (no configuration)
> > checking for MCA component allocator:bucket compile mode... static
> > checking if MCA component allocator:bucket can compile... yes
> > ../configure: line 123247: syntax error near unexpected token `('
> > ../configure: line 123247: ` { $as_echo "$as_me:$LINENO: WARNING: This component was selected as the default (direct call)" >&5'
> >
> > Have no idea of why I should need an MCA bucket but it seems
> > to trigger a problem. If I hack out the parentheses I end up
> > hitting more parenthetic syntax errors.
> >
> > Any suggestions gratefully received.
> >
> >
> > k.mcmanus_at_[hidden] - http://staffweb.cms.gre.ac.uk/~k.mcmanus
> > --------------------------------------------------------------
> > Dr Kevin McManus Queen Mary 413
> > School of Computing & Mathematical Sciences,
> > University of Greenwich,
> > Old Royal Naval College,
> > Park Row, Greenwich, Tel +44 (0)208 331 8719
> > London, SE10 9LS Fax +44 (0)208 331 8665
> > --------------------------------------------------------------
> >
> > University of Greenwich, a charity and company limited by
> > guarantee, registered in England (reg no. 986729)
> > Registered Office: Old Royal Naval College
> > _______________________________________________
> > users mailing list
> > users_at_[hidden]
> > http://www.open-mpi.org/mailman/listinfo.cgi/users
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users