Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] Linux opteron infiniband sunstudio configure problem
From: Terry Dontje (Terry.Dontje_at_[hidden])
Date: 2009-03-30 08:31:40


Sorry for the delay in response, I was out of the office late last week.

Can you tell me what version of Open MPI you are trying to build (1.2 or 1.3 branch)? Are you using the tarball on the Open MPI site or code downloaded from the svn repository? Can you tell me which distribution and version of Linux you are on and the version of Sun Studio you are using?

When I build on Linux using Sun Studio I don't put x86_64 in the configure line so I am not sure why that was necessary and wonder it there still is an issue here.

--td
> Message: 1
> Date: Thu, 26 Mar 2009 16:52:28 +0000
> From: Kevin McManus <k.mcmanus_at_[hidden]>
> Subject: [OMPI users] Linux opteron infiniband sunstudio configure
> problem
> To: users_at_[hidden]
> Message-ID: <20090326165228.GC26276_at_[hidden]>
> Content-Type: text/plain; charset=us-ascii
>
>
> Hi All,
>
> As a complete beginner (to OpenMPI) I am attempting to build on
> a Linux opteron infiniband platform using SunStudio compilers.
>
> My build script looks like...
>
> #!/bin/sh
>
> ../configure x86_64 \
> CC=cc CXX=CC F77=f77 FC=f90 \
> CFLAGS=-m64 CXXFLAGS=-m64 FFLAGS=-m64 FCFLAGS=-m64 \
> --enable-static \
> --enable-orterun-prefix-by-default \
> --enable-mpi-f90 \
> --enable-mpi-threads \
> --with-psm
>
> Not sure why I need to put x86_64 as the first argument, just a lucky
> guess after...
>
> configure: error: cannot guess build type; you must specify one
>
> ...but I hit another problem...
>
> --- MCA component allocator:basic (no configuration)
> checking for MCA component allocator:basic compile mode... static
> checking if MCA component allocator:basic can compile... yes
>
> --- MCA component allocator:bucket (no configuration)
> checking for MCA component allocator:bucket compile mode... static
> checking if MCA component allocator:bucket can compile... yes
> ../configure: line 123247: syntax error near unexpected token `('
> ../configure: line 123247: ` { $as_echo "$as_me:$LINENO: WARNING: This component was selected as the default (direct call)" >&5'
>
> Have no idea of why I should need an MCA bucket but it seems
> to trigger a problem. If I hack out the parentheses I end up
> hitting more parenthetic syntax errors.
>
> Any suggestions gratefully received.
>
>
> k.mcmanus_at_[hidden] - http://staffweb.cms.gre.ac.uk/~k.mcmanus
> --------------------------------------------------------------
> Dr Kevin McManus Queen Mary 413
> School of Computing & Mathematical Sciences,
> University of Greenwich,
> Old Royal Naval College,
> Park Row, Greenwich, Tel +44 (0)208 331 8719
> London, SE10 9LS Fax +44 (0)208 331 8665
> --------------------------------------------------------------
>
> University of Greenwich, a charity and company limited by
> guarantee, registered in England (reg no. 986729)
> Registered Office: Old Royal Naval College
>