Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] [Fwd: Re: Configure OpenMPI and SLURM on Debian (Lenny)]
From: Jerome BENOIT (ml.jgmbenoit_at_[hidden])
Date: 2009-03-27 08:34:09


Hello List,

Manuel Prinz wrote:
> Am Freitag, den 27.03.2009, 11:01 +0800 schrieb Jerome BENOIT:
>> Finally I succeeded with the sbatch approach ... when my firewall are
>> stopped !
>> So I guess that I have to configure my firewall (I use firehol):
>> I have just tried but without success. I will try again later.
>> Is there any other ports than the SLURM ones which are involved ?
>
> On the SLURM side, you have to open the ports to the SLURM control
> daemons and the service that handles the credentials. On Debian systems
> that's MUNGE.

The SLURM part seems to be fine, as I used for nearly one year.

>
> Also, you need to open ports for the MPI processes to communicate. The
> port range is rather wide, so the easiest setup (I guess) is to not use
> a firewall between computing nodes.

Indeed, but I do not like the idea as far as ``my'' cluster is concerned.

I realized this part of the story before to read the email.
On version 1.3.0 , there is new options which allow to specify
the open ports: [oon|btl]_tcp_port_[min|rnage]_v4
I have just tried the Sid package (1.3-2), but it does not work properly
(when the firewall are off)

I get (orange being the name of the node)

[orange:17336] bind() failed: Permission denied (13)
[orange:17336] mca_oob_tcp_init: unable to create IPv4 listen socket: Error
.........................

I have just read that the current stable version for OpenMPI is now 1.3.1:
I will give it a try once it will be packaged in Sid.

>
> Best regards
> Manuel
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>