Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] PATH_MAX error with compiling openmpi 1.3.1 with intel compilers
From: Rene Salmon (salmr0_at_[hidden])
Date: 2009-03-23 15:34:16


Hi,

In the release notes for openmpi-1.3.1 there was this:

- Fix a few places where we used PATH_MAX instead of OMPI_PATH_MAX,
   leading to compile problems on some platforms. Thanks to Andrea Iob
   for the bug report.

I guess maybe all the places where PATH_MAX appears did not get
replaced?

Here is what i get when I try to compile openmpi 1.3.1 with intel
compilers l_cc_p_10.1.021:

icc -DHAVE_CONFIG_H -I. -I.. -I../tools/opari/lib -I../extlib/otf/otflib
-I../ex
tlib/otf/otflib -D_GNU_SOURCE -DBINDIR=
\"/hpc/soft/openmpi/x86_64/1.3.1/tcp/
bin\" -DDATADIR=\"/hpc/soft/openmpi/x86_64/1.3.1/tcp/share/vampirtrace\"
-DRFG -
DVT_BFD -DVT_MEMHOOK -DVT_IOWRAP -static-intel -MT vt_error.o -MD -MP
-MF .deps
/vt_error.Tpo -c -o vt_error.o vt_error.c
mv -f .deps/vt_error.Tpo .deps/vt_error.Po
icc -DHAVE_CONFIG_H -I. -I.. -I../tools/opari/lib -I../extlib/otf/otflib
-I../ex
tlib/otf/otflib -D_GNU_SOURCE -DBINDIR=
\"/hpc/soft/openmpi/x86_64/1.3.1/tcp/
bin\" -DDATADIR=\"/hpc/soft/openmpi/x86_64/1.3.1/tcp/share/vampirtrace\"
-DRFG -
DVT_BFD -DVT_MEMHOOK -DVT_IOWRAP -static-intel -MT vt_metmap.o -MD -MP
-MF .dep
s/vt_metmap.Tpo -c -o vt_metmap.o vt_metmap.c
mv -f .deps/vt_metmap.Tpo .deps/vt_metmap.Po
icc -DHAVE_CONFIG_H -I. -I.. -I../tools/opari/lib -I../extlib/otf/otflib
-I../ex
tlib/otf/otflib -D_GNU_SOURCE -DBINDIR=
\"/hpc/soft/openmpi/x86_64/1.3.1/tcp/
bin\" -DDATADIR=\"/hpc/soft/openmpi/x86_64/1.3.1/tcp/share/vampirtrace\"
-DRFG -
DVT_BFD -DVT_MEMHOOK -DVT_IOWRAP -static-intel -MT vt_otf_gen.o -MD -MP
-MF .de
ps/vt_otf_gen.Tpo -c -o vt_otf_gen.o vt_otf_gen.c
vt_otf_gen.c(117): error: identifier "PATH_MAX" is undefined
    char name[PATH_MAX];
                             ^

compilation aborted for vt_otf_gen.c (code 2)
make[5]: *** [vt_otf_gen.o] Error 2
make[5]: Leaving directory `/tmp/openmpi-1.3.1/ompi/contrib/vt/vt/vtlib'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/tmp/openmpi-1.3.1/ompi/contrib/vt/vt'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/tmp/openmpi-1.3.1/ompi/contrib/vt/vt'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/tmp/openmpi-1.3.1/ompi/contrib/vt'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/openmpi-1.3.1/ompi'
make: *** [all-recursive] Error 1

Seems like ompi/contrib/vt/vt/vtlib/vt_otf_gen.c and
ompi/contrib/vt/vt/vtlib/vt_thrd.c need to be updated as well.

I took the relevant parts of Andrea Iob's patch for the two files above
and tried again and things compiled fine.
http://www.open-mpi.org/community/lists/users/2009/01/7785.php

Rene