Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Compiling Open MPI with PGI compilers in 32-bit mode
From: Michael Jennings (mej_at_[hidden])
Date: 2009-03-20 14:36:29


On Friday, 20 March 2009, at 12:49:06 (-0500),
Ethan Mallove wrote:

> Has anyone successfully compiled Open MPI with the PGI compilers in
> 32-bit mode (e.g., using -tp=k8-32 flag)? I am getting the following
> error with 32-bit:
>
> $ cd opal/mca/memory/ptmalloc2
> $ make
> /bin/sh ../../../../libtool --tag=CC --mode=link pgcc -O -DNDEBUG -tp=k8-32 -export-dynamic -o libopenmpi-malloc.la -rpath /opt/SUNWhpc/HPC8.2/pgi/lib malloc.lo malloc-stats.lo -lnsl -lutil -lpthread
> libtool: link: pgcc -shared -fpic -DPIC .libs/malloc.o .libs/malloc-stats.o -lnsl -lutil -lpthread -lc -Wl,-soname -Wl,libopenmpi-malloc.so.0 -o .libs/libopenmpi-malloc.so.0.0.0

I see "-tp=k8-32" in your libtool line but not in the actual link
command. Have you tried adding that flag to your LDFLAGS in addition
to your CFLAGS?

> /usr/bin/ld: warning: i386 architecture of input file `.libs/malloc.o' is incompatible with i386:x86-64 output
> /usr/bin/ld: warning: i386 architecture of input file `.libs/malloc-stats.o' is incompatible with i386:x86-64 output

This indicates to me that the linker is trying to generate 64-bit
output, which would make sense if the flag to generate 32-bit output
never made it to the linker.

Michael

-- 
Michael Jennings <mej_at_[hidden]>
Linux Systems and Cluster Admin
UNIX and Cluster Computing Group