Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] mpirun hangs when launching job on remote node
From: Raymond Wan (rwan_at_[hidden])
Date: 2009-03-18 05:39:41


Hi Bogdan,

Thanks for the information and looking forward to the new OpenMPI feature of port restriction...

About Debian, I was wondering about that...I've had no problems with it and I was thinking everything was just done for me; of course, another possibility is that there was no firewall to begin with and I didn't know about it. Alas, it's the latter...I better look into it as I was basically oblivious to the lack of a firewall...

Ray

Bogdan Costescu wrote:
> On Wed, 18 Mar 2009, Raymond Wan wrote:
>
>> Perhaps it has something to do with RH's defaults for the firewall
>> settings?
>
> If your sysadmin uses kickstart to configure the systems, (s)he has to
> add 'firewall --disabled'; similar for SELinux which seems to have
> caused problems to another person on this list. OTOH, if (s)he blindly
> copied the config for a workstation to a cluster node, maybe some more
> education is needed first...
>
>> Another system that worked "immediately" was a Debian system.
>
> That's because Debian doesn't configure a firewall or SELinux, leaving
> the admin the responsability to do it.
>
>> Anyway, if you find out a solution that doesn't require the firewall
>> to be turned off, please let me know -- I think our sysadmin would be
>> interested, too.
>
> Depending on your definition of 'firewall turned off', the new feature
> of restricting ports used by OpenMPI will help. The firewall can stay
> on, but it should be configured to open a range of ports used by OpenMPI.
>