Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] core dump while running openmpi
From: Terry Frankcombe (terry_at_[hidden])
Date: 2009-03-14 21:03:01


Looks like I'm the first to say it: 1.1.1 is very, very old.

Are you saying that you want to install with 1.1.1 because your code is
known to work with it, or that it's known not to work with later
versions (1.3 is released)?

Either way, a later OMPI version is what you want. If your app doesn't
work with a later version you need to work out why and fix it.

On Sat, 2009-03-14 at 13:08 -0700, Ted Yu wrote:
> Hi there:
>
> I'm trying to install an old version of openmpi 1.1.1 on a 32 bit
> cluster and running a program with it. This program runs fine for
> another 64 bit cluster which has openmpi 1.1.1 installed, but when
> running this on the 32 bit cluster, I get the following error:
>
> /var/spool/pbs/mom_priv/jobs/282832.borg.SC: line 37: 13154
> Segmentation fault (core
> dumped) /ul/tedhyu/openmpi/openmpi-1.1.1/install/bin/mpirun
> -machinefile ${PBS_NODEFILE} -np ${NPROCS} ${CODE}
>
> Has anybody encountered this error before? If you have any advice, it
> would be much appreciated.
>
> Regards,
>
> Ted
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users