Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] PGI 8.0-4 doesn't like ompi/mca/op/op.h
From: Prentice Bisbal (prentice_at_[hidden])
Date: 2009-03-13 09:18:22


Mark Potts wrote:
> All,
> I don't know PGI's compilers, but is it possible that since "restrict"
> was supposedly introduced as a C99 feature that it is not supported
> by default by their C compiler? This would explain the wording of
> the error message which indicates interpretation of "restrict" as a
> variable name.
>
> Perhaps, like gcc, there is a -std=c99 option for the PGI compiler?
>

I just searched the user guide that came with 8.0-3. It mentions that
pgcc supports C99, but doesn't mention any compile-time options for it.
However, the output of 'pgcc --help | grep -i c99' shows these options:

-c99 Use the C99 language
-c9x == -c99

-- 
Prentice