Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] PGI 8.0-4 doesn't like ompi/mca/op/op.h
From: Ralph Castain (rhc_at_[hidden])
Date: 2009-03-12 23:29:06


I believe Mostyn's error is due to a change in PGI 8.0-x from earlier
releases (PGI has been known to do these kind of things). My point was
only that PGI is a tad different from our other compilers, and that we
do typically see kernel-related issues as well. So one needs to watch
out for PGI compiler issues.

Note a recent commit by Rainer on the trunk relating to PGI compile
issues on a different kernel...where we haven't seen those problems
before on any of the kernels here. :-)

On Mar 12, 2009, at 9:22 PM, Jeff Squyres wrote:

> On Mar 12, 2009, at 11:17 PM, Ralph Castain wrote:
>
>> I believe I reported this before on a different mailing list, but
>> will
>> repeat it here. The PGI compilers rely on the Linux kernel for some
>> things. We found that the ability of the PGI compilers to build OMPI,
>> therefore, was highly dependent upon the specific Linux kernel on the
>> machine.
>>
>
> The error Mostyn was reporting seem to be related to the "restrict"
> keyword -- not particular kernel or glibc functionality.
>
> Never say "never" though; I'll admit that the inner workings of
> compilers are a mystery to me. :-)
>
> --
> Jeff Squyres
> Cisco Systems
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users