Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] PGI 8.0-4 doesn't like ompi/mca/op/op.h
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2009-03-12 23:22:16


On Mar 12, 2009, at 11:17 PM, Ralph Castain wrote:

> I believe I reported this before on a different mailing list, but will
> repeat it here. The PGI compilers rely on the Linux kernel for some
> things. We found that the ability of the PGI compilers to build OMPI,
> therefore, was highly dependent upon the specific Linux kernel on the
> machine.
>

The error Mostyn was reporting seem to be related to the "restrict"
keyword -- not particular kernel or glibc functionality.

Never say "never" though; I'll admit that the inner workings of
compilers are a mystery to me. :-)

-- 
Jeff Squyres
Cisco Systems