Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] pcart_coords_f.c:74: error: lvalue requiredasdecrement operand
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2009-03-11 11:47:38


On Mar 11, 2009, at 10:19 AM, Yu Chen wrote:

> Thanks for the quick reply.
> I think this is the same as this thread in development email list:
> http://www.open-mpi.org/community/lists/devel/2009/02/5367.php
>

Ah, yes it probably is.

> It seems this is going to be fixed in 1.3.1, but meanwhile is there an
> easy way to get around for now?
>

Are you compiling with -i8, perchance? If so, there probably isn't an
easy workaround other than to take the latest Open MPI 1.3.1rc tarball
(should be pretty close to the final version).

     http://www.open-mpi.org/software/ompi/v1.3/

> I will send all the information in next email if you would still like
> to look at it.
>

If this is the same issue, then it's probably not worth it.

-- 
Jeff Squyres
Cisco Systems