Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Lahey 64 bit and openmpi 1.3?
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2009-03-05 17:30:45


On Mar 5, 2009, at 5:14 PM, Tiago Silva wrote:

> I am reporting what I found out for the benefit of other lahey users
> out
> there. I have been told by people at Lahey that libtool has been
> updated
> to support their compiler.
> http://www.linux-archive.org/archlinux-development/156171-libtool-2-2-6a-1-a.html
>

Odd. This release says that LLT 2.2.6 is the one that supports
Lahey. But that's the version we ship in Open MPI. :-\ This is from
an expanded OMPI 1.3 tarball:

-----
[14:22] svbu-mpi:/home/jsquyres/openmpi-1.3 % ./libtool --version
ltmain.sh (GNU libtool) 2.2.6
Written by Gordon Matzigkeit <gord_at_[hidden]>, 1996

Copyright (C) 2008 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There
is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR
PURPOSE.
[14:29] svbu-mpi:/home/jsquyres/openmpi-1.3 %
-----

So it looks like something is lacking in the Lahey compiler support.

The announcement did specifically mention Lahey 8.1 -- is that what
you have?

-- 
Jeff Squyres
Cisco Systems