Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] libnuma under ompi 1.3
From: Ralph Castain (rhc_at_[hidden])
Date: 2009-03-04 11:39:41


Problem is that some systems install both 32 and 64 bit support, and
build OMPI both ways. So we really can't just figure it out without
some help.

At our location, we simply take care to specify the -L flag to point
to the correct version so we avoid any confusion.

On Mar 4, 2009, at 8:37 AM, Prentice Bisbal wrote:

> Jeff,
>
> See my reply to Dr. Frankcombe's original e-mail. I've experienced
> this
> same problem with the PGI compilers, so this isn't limited to just the
> Intel compilers. I provided a fix, but I think OpenMPI should be
> able to
> figure out and add the correct linker flags during the
> configuration/build stage.
>
> Jeff Squyres wrote:
>> Hmm; that's odd.
>>
>> Is icc / icpc able to find libnuma with no -L, but ifort is unable to
>> find it without a -L?
>>
>> On Mar 3, 2009, at 10:00 PM, Terry Frankcombe wrote:
>>
>>> Having just downloaded and installed Open MPI 1.3 with ifort and
>>> gcc, I
>>> merrily went off to compile my application.
>>>
>>> In my final link with mpif90 I get the error:
>>>
>>> /usr/bin/ld: cannot find -lnuma
>>>
>>> Adding --showme reveals that
>>>
>>> -I/home/terry/bin/Local/include -pthread -I/home/terry/bin/Local/lib
>>>
>>> is added to the compile early in the aggregated ifort command, and
>>>
>>> -L/home/terry/bin/Local/lib -lmpi_f90 -lmpi_f77 -lmpi -lopen-rte
>>> -lopen-pal -lpbs -lnuma -ldl -Wl,--export-dynamic -lnsl -lutil -lm
>>> -ldl
>>>
>>> is added to the end.
>>>
>>> I note than when compiling Open MPI -lnuma was visible in the gcc
>>> arguments, with no added -L.
>>>
>>> On this system libnuma.so exists in /usr/lib64. My (somewhat long!)
>>> configure command was
>>>
>>> ./configure --enable-static --disable-shared
>>> --prefix=/home/terry/bin/Local --enable-picky --disable-
>>> heterogeneous
>>> --without-slurm --without-alps --without-xgrid --without-sge
>>> --without-loadleveler --without-lsf F77=ifort
>>>
>>>
>>> Should mpif90 have bundled a -L/usr/lib64 in there somewhere?
>>>
>>> Regards
>>> Terry
>>>
>>>
>>> --
>>> Dr. Terry Frankcombe
>>> Research School of Chemistry, Australian National University
>>> Ph: (+61) 0417 163 509 Skype: terry.frankcombe
>>
>
>
> --
> Prentice
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users