Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: [OMPI users] libmpi_f90.so not being built
From: Tiago Silva (tsilva_at_[hidden])
Date: 2009-02-27 06:38:25


Hi,

I am trying to build openmpi 1.3 on Cent_OS with gcc and the lahey f95
compiler with the following configuration:

./configure F77=/share/apps/lf6481/bin/lfc FC=/share/apps/lf6481/bin/lfc
   --prefix=/opt/openmpi-1.3_lfc

When I "make install all" the process fails to build libmpi_f90.la
because libmpi_f90.so.0 isn't found (see output at the end of the
post). I can't grep any other mention to libmpi_f90.so being built in
config.log or on the output from the make and indeed it is not on the
build directory with the other shared libraries:

[root_at_server lfc]# find . -name "libmpi*.so*"
./ompi/.libs/libmpi.so
./ompi/.libs/libmpi.so.0
./ompi/.libs/libmpi.so.0.0.0
./ompi/.libs/libmpi.so.0.0.0T
./ompi/mpi/cxx/.libs/libmpi_cxx.so.0.0.0
./ompi/mpi/cxx/.libs/libmpi_cxx.so.0.0.0T
./ompi/mpi/cxx/.libs/libmpi_cxx.so.0
./ompi/mpi/cxx/.libs/libmpi_cxx.so
./ompi/mpi/f77/.libs/libmpi_f77.so.0
./ompi/mpi/f77/.libs/libmpi_f77.so.0.0.0
./ompi/mpi/f77/.libs/libmpi_f77.so
./ompi/mpi/f77/.libs/libmpi_f77.so.0.0.0T

I believe that shared libraries for f90 bindings should be built by
default but even trying to force the f90 bindings with shared libraries
didn't do the trick:

./configure F77=/share/apps/lf6481/bin/lfc FC=/share/apps/lf6481/bin/lfc
  F90=/share/apps/lf6481/bin/lfc --prefix=/opt/openmpi-1.3_lfc
--enable-shared --with-mpi_f90_size=medium --enable-mpi-f90

Any sugestions of what might be going wrong are most welcome.

Thanks,
TS

[root_at_server lfc]# tail install.out
make[4]: Entering directory `/root/builds/openmpi-1.3/lfc/ompi/mpi/f90'
make[5]: Entering directory `/root/builds/openmpi-1.3/lfc'
make[5]: Leaving directory `/root/builds/openmpi-1.3/lfc'
/bin/sh ../../../libtool --mode=link /share/apps/lf6481/bin/lfc
-I../../../omp
i/include -I../../../ompi/include -I. -I. -I../../../ompi/mpi/f90
-export-dyn
amic -o libmpi_f90.la -rpath /opt/openmpi-1.3_lfc/lib mpi.lo
mpi_sizeof.lo mpi
_comm_spawn_multiple_f90.lo mpi_testall_f90.lo mpi_testsome_f90.lo
mpi_waitall_f
90.lo mpi_waitsome_f90.lo mpi_wtick_f90.lo mpi_wtime_f90.lo
../../../ompi/libm
pi.la -lnsl -lutil -lm
libtool: link: /share/apps/lf6481/bin/lfc -shared .libs/mpi.o
.libs/mpi_sizeof.
o .libs/mpi_comm_spawn_multiple_f90.o .libs/mpi_testall_f90.o
.libs/mpi_testsome
_f90.o .libs/mpi_waitall_f90.o .libs/mpi_waitsome_f90.o
.libs/mpi_wtick_f90.o .l
ibs/mpi_wtime_f90.o -rpath /root/builds/openmpi-1.3/lfc/ompi/.libs
-rpath /ro
ot/builds/openmpi-1.3/lfc/orte/.libs -rpath
/root/builds/openmpi-1.3/lfc/opal/.l
ibs -rpath /opt/openmpi-1.3_lfc/lib
-L/root/builds/openmpi-1.3/lfc/orte/.libs -L
/root/builds/openmpi-1.3/lfc/opal/.libs ../../../ompi/.libs/libmpi.so
/root/buil
ds/openmpi-1.3/lfc/orte/.libs/libopen-rte.so
/root/builds/openmpi-1.3/lfc/opal/.
libs/libopen-pal.so -ldl -lnsl -lutil -lm -pthread -soname
libmpi_f90.so.0 -o
  .libs/libmpi_f90.so.0.0.0
ERROR -- Could not find specified object file libmpi_f90.so.0.
make[4]: Leaving directory `/root/builds/openmpi-1.3/lfc/ompi/mpi/f90'
make[3]: Leaving directory `/root/builds/openmpi-1.3/lfc/ompi/mpi/f90'
make[2]: Leaving directory `/root/builds/openmpi-1.3/lfc/ompi/mpi/f90'
make[1]: Leaving directory `/root/builds/openmpi-1.3/lfc/ompi'