Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Problems in 1.3 loading shared libs when using VampirServer
From: michael.meinel_at_[hidden]
Date: 2009-02-24 10:29:06


Hello,

I have a runtime-linking problem with MPI 1.3 that is very similar.

We apply MPI in a Python-based framework. For some platforms we use a
patched Python version that does the MPI_Init() call.
On some machines we use an unmodified Python with a small module
(minimpi) that cares for the MPI_Init/Finalize calls.

Starting with OpenMPI 1.3 the minimpi module crashes with the error
".../mca_paffinity_linux.so: undefined symbol: mca_base_param_reg_int".

Upon further investigation, it seems to be a problem similar to this:
http://www.open-mpi.org/community/lists/devel/2005/09/0359.php
The dynamic parts of the library are however no more linked against
their frameworks.

Is there a chance, that another student will do this job? Or are there
any practical hints on how to solve this problem?

To try it out yourself, please feel free to use the attached code.
 * Make sure to adapt the pathes to your OpenMPI implementation in
setup.py
 * Run "setup.py install"
 * Start Python
 * type "import minimpi" and the application should crash.

Regards, Michael Meinel

PS: Please excuse the absence of any citations but I just joined the
list (due to this problem).

---
German Aerospace Center (DLR) in the Helmholtz-Association
Center for Computer Applications in Aerospace Science and Engineering
Brunswick, Germany