Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: [OMPI users] OpenMPI 1.3.1 rpm build error
From: Jim Kusznir (jkusznir_at_[hidden])
Date: 2009-02-19 12:00:59


Hi all:

I'm trying to build openmpi RPMs from the included spec file. The
build fails with:

gcc -DHAVE_CONFIG_H -I. -I.. -I../tools/opari/lib
-I../extlib/otf/otflib -I../extlib/otf/otflib -D_GNU_SOURCE
-DBINDIR=\"/opt/openmpi-gcc/1.3/bin\"
-DDATADIR=\"/opt/openmpi-gcc/1.3/share\" -DRFG -DVT_BFD -DVT_MEMHOOK
-DVT_IOWRAP -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -MT
vt_iowrap.o -MD -MP -MF .deps/vt_iowrap.Tpo -c -o vt_iowrap.o
vt_iowrap.c
vt_iowrap.c:1242: error: expected declaration specifiers or '...'
before numeric constant
vt_iowrap.c:1243: error: conflicting types for '__fprintf_chk'
make[5]: *** [vt_iowrap.o] Error 1

My build command was:
rpmbuild -bb --define 'install_in_opt 1' --define 'install_modulefile
1' --define 'modules_rpm_name environment-modules' --define
'build_all_in_one_rpm 0' --define 'configure_options
--with-tm=/opt/torque --with-openib=/opt/mlnx-ofed/src/OFED-1.3.1'
--define '_name openmpi-gcc' openmpi-1.3.spec

This build for the 1.2.8 worked fine; this is my first attempt at
building 1.3.1.
The system is Rocks 5.1 (CentSO 5.2), GCC 4.1.2-42 (CentOS 5.2 default).

Any suggestions?

Thanks!