Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] OpenMPI and Valgrind
From: George Bosilca (bosilca_at_[hidden])
Date: 2009-02-12 16:30:27


Some of the configure options changed their name for the 1.3. Here is
the updated list you should use in order to get valgrind support for
the 1.3:

--enable-memchecker --with-valgrind --with-memory-manager=none

   george.

On Feb 12, 2009, at 16:23 , Reuben D. Budiardja wrote:

> On Thursday 12 February 2009 11:50:07 am Ashley Pittman wrote:
>>
>>> I am using OpenMPI-1.2.8 with all the default configure option. What
>>> should I
>>> do to be able use Valgrind with program compiled by OpenMPI ?
>>
>> From memory and reading the above links (i.e. untested advice):
>> 1) Use OpenMPI 1.3 where the default is not to include this.
>
> I tried it with OpenMPI 1.3, I didn't give any configure option
> except --prefix, and Valgrind still does not work as expected.
>
>> 2) Configure Open MPI 1.2.8 with the --disable-memory-manager option
>
> Tried this, no luck either. The option doesn't seem to be doing
> anything, and
> it's not even listed as option with "./configure --help".
>
>> 3) Compile you application without the -lopen-pal otion. In practice
>> this means running "mpicc --show" and cut-and pasting the underlying
>> compile line without the -lopen-pal into your application build
>> procedure. I was able to do this for hello world but I can image
>> it'll
>> be a real PITA for anything larger.
>
> Yes, I tried this before, and for a very small test program this
> seems to
> work. But as you said, this would a real pain to do..
>
> Thanks.
> RDB
> --
> Reuben D. Budiardja
> Dept. Physics and Astronomy
> University of Tennessee, Knoxville, TN
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users