Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] OpenMPI and Valgrind
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2009-02-12 16:30:02


On Feb 12, 2009, at 1:23 PM, Reuben D. Budiardja wrote:

>> From memory and reading the above links (i.e. untested advice):
>> 1) Use OpenMPI 1.3 where the default is not to include this.
>
> I tried it with OpenMPI 1.3, I didn't give any configure option
> except --prefix, and Valgrind still does not work as expected.

Open MPI v1.3 does not include a memory manager by default, so it's
possible that something else is going on here to interfere with
Valgrind's behavior. Or it could be that Valgrind simply won't catch
this error.

>> 2) Configure Open MPI 1.2.8 with the --disable-memory-manager option
>
> Tried this, no luck either. The option doesn't seem to be doing
> anything, and
> it's not even listed as option with "./configure --help".

Try --without-memory-manager (not --disable).

>> 3) Compile you application without the -lopen-pal otion. In practice
>> this means running "mpicc --show" and cut-and pasting the underlying
>> compile line without the -lopen-pal into your application build
>> procedure. I was able to do this for hello world but I can image
>> it'll
>> be a real PITA for anything larger.
>
> Yes, I tried this before, and for a very small test program this
> seems to
> work. But as you said, this would a real pain to do..

This won't work in practice; OMPI *needs* the open-pal library, and
for shared library builds, it will pull it in by default anyway.

-- 
Jeff Squyres
Cisco Systems