Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] OpenMPI and Valgrind
From: Reuben D. Budiardja (techlist_at_[hidden])
Date: 2009-02-12 16:23:35


On Thursday 12 February 2009 11:50:07 am Ashley Pittman wrote:
>
> > I am using OpenMPI-1.2.8 with all the default configure option. What
> > should I
> > do to be able use Valgrind with program compiled by OpenMPI ?
>
> From memory and reading the above links (i.e. untested advice):
> 1) Use OpenMPI 1.3 where the default is not to include this.

I tried it with OpenMPI 1.3, I didn't give any configure option
except --prefix, and Valgrind still does not work as expected.

> 2) Configure Open MPI 1.2.8 with the --disable-memory-manager option

Tried this, no luck either. The option doesn't seem to be doing anything, and
it's not even listed as option with "./configure --help".

> 3) Compile you application without the -lopen-pal otion. In practice
> this means running "mpicc --show" and cut-and pasting the underlying
> compile line without the -lopen-pal into your application build
> procedure. I was able to do this for hello world but I can image it'll
> be a real PITA for anything larger.

Yes, I tried this before, and for a very small test program this seems to
work. But as you said, this would a real pain to do..

Thanks.
RDB

-- 
Reuben D. Budiardja
Dept. Physics and Astronomy
University of Tennessee, Knoxville, TN