Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] strange error, seems inable to launch job
From: Ralph Castain (rhc_at_[hidden])
Date: 2009-02-11 10:04:17


Never seen that one before, though we did put the test in there "just
in case".

Basically, this message indicates that the system returned an error
when we attempted to dup2 the stdout/err file descriptors so we could
setup a pipe by which we can forward that output to you.

I have no idea why the system would refuse the request. You might
check your fd limits to see if they are strangely low, or write a
little test program to see if there is something strange about pipe
permissions.

Most likely thing I can think of, though, is that you possibly are
picking up incompatible libraries, or something got crosswise during
build.

Ralph

On Feb 11, 2009, at 3:10 AM, Mr Yann JOBIC wrote:

> Hello all,
>
> I compiled ompi v1.3 (tarball) with the intel compiler on debian
> etch. Everything went fine, thanks for the FAQ (quite complet)
>
> But, when i'm running a job, i've got this error :
> Trixy03-jobic% mpirun --verbose --debug-daemons -np 4 ./exe
> [Trixy03:15140] [[19525,0],0] orted_cmd: received add_local_procs
> [Trixy03:15140] [[19525,0],0] node[0].name Trixy03 daemon 0 arch
> ffc91200
> --------------------------------------------------------------------------
> mpirun was unable to launch the specified application as it
> encountered an error:
>
> Error: pipe function call failed when setting up I/O forwarding
> subsystem
> Node: Trixy03
>
> while attempting to start process rank 0.
> --------------------------------------------------------------------------
>
> I don't understand what's going on, and how to debug...
> I compiled mpich1, and i can successfully launch a job.
>
> Have you got some ideas of what's going on ?
>
> Many thanks,
>
> Yann
>
> PS : Some possible interesting information :
> Open MPI SVN revision: r20295
> Open MPI release date: Jan 19, 2009
> Open RTE: 1.3
> Build CFLAGS: -DNDEBUG -mp1 -m64 -O3 -fno-alias -msse3 -static-intel
> -finline-functions -fno-strict-aliasing
> -restrict -fexceptions -pthread -
> fvisibility=hidden
> Build CXXFLAGS: -DNDEBUG -mp1 -m64 -O3 -fno-alias -msse3 -static-
> intel -finline-functions -fexceptions -pthread
> Build FFLAGS: -mp1 -m64 -O3 -fno-alias -msse3 -static-intel -
> fexceptions
> Build FCFLAGS: -mp1 -m64 -O3 -fno-alias -msse3 -static-intel -
> fexceptions -fexceptions
> Build LDFLAGS: -export-dynamic -fexceptions
> Build LIBS: -lnsl -lutil Wrapper extra CFLAGS: -fexceptions -pthread
> Wrapper extra CXXFLAGS: -fexceptions -pthread
> Wrapper extra FFLAGS: -fexceptions
> Wrapper extra FCFLAGS: -fexceptions
> Wrapper extra LDFLAGS: Wrapper extra LIBS: -ldl -Wl,--export-
> dynamic -lnsl -lutil
>
>
>
> --
> ___________________________
>
> Yann JOBIC
> HPC engineer
> Polytech Marseille DME
> IUSTI-CNRS UMR 6595
> Technopôle de Château Gombert
> 5 rue Enrico Fermi
> 13453 Marseille cedex 13
> Tel : (33) 4 91 10 69 39
> ou (33) 4 91 10 69 43
> Fax : (33) 4 91 10 69 69
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users