Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Linux Itanium Configure and Make Logs for 1.2.8
From: Joe Griffin (joe.griffin_at_[hidden])
Date: 2009-02-09 18:25:10


Tony,

 

My compile line with the error was the following. I believe the one you
had with the error was similar:

 

icc -DHAVE_CONFIG_H -I. -I../../opal/include -I../../orte/include
-I../../ompi/include -I../../opal/mca/paffinity/linux/plpa/src/libplpa
-I../.. \

-O3 -DNDEBUG -finline-functions -fno-strict-aliasing -restrict -MT
atomic-asm.lo -MD -MP -MF .deps/atomic-asm.Tpo -c atomic-asm.S -fPIC
-DPIC -o .libs/atomic-asm.o

 

However, your 1.2.8 output had:

 

icc -DHAVE_CONFIG_H -I. -I../../opal/include -I../../orte/include
-I../../ompi/include -I../.. \

-O3 -DNDEBUG -finline-functions -fno-strict-aliasing -restrict -pthread
-MT asm.lo -MD -MP -MF .deps/asm.Tpo -c asm.c -fPIC -DPIC -o
.libs/asm.o

 

If I use these options, the error goes away. Here is output from my
screen:

 

ia64b <94> pwd

/scratch/open13/openmpi-1.3/opal/asm

 

ia64b <95> icc -DHAVE_CONFIG_H -I. -I../../opal/include
-I../../orte/include -I../../ompi/include
-I../../opal/mca/paffinity/linux/plpa/src/libplpa -I../.. -O3 -DNDEBUG
-finline-functions -fno-strict-aliasing -restrict -MT atomic-asm.lo -MD
-MP -MF .deps/atomic-asm.Tpo -c atomic-asm.S -fPIC -DPIC -o
.libs/atomic-asm.o

/scratch/icc777XKf.s(1) : error A2040: Unexpected token: Unary Diez
Operator at: Start

/scratch/icc777XKf.s(2) : error A2040: Unexpected token: Unary Diez
Operator at: Start

/scratch/icc777XKf.s(3) : error A2040: Unexpected token: Unary Diez
Operator at: Start

/scratch/icc777XKf.s(4) : error A2040: Unexpected token: Unary Diez
Operator at: Start

.libs/atomic-asm.o - 4 error(s), 0 warning(s)

 

ia64b <96> icc -DHAVE_CONFIG_H -I. -I../../opal/include
-I../../orte/include -I../../ompi/include -I../.. -O3 -DNDEBUG
-finline-functions -fno-strict-aliasing -restrict -pthread -MT asm.lo
-MD -MP -MF .deps/asm.Tpo -c asm.c -fPIC -DPIC -o .libs/asm.o

 

ia64b <97> ls -l .libs/asm.o

-rw-r--r-- 1 jjg develop 472 Feb 9 16:27 .libs/asm.o

 

So ... for some reasons the compiler options changed. Can you please

 

1. cd into the .../opal/asm directory

2. Issue the BAD command I have at my prompt 95 and verify the error.

3. Issue the GOOD command I have at my prompt 96 and verify it works.

 

Now .. as to why the options are different .. .I don't know.

 

Just trying to help,

Joe

 

 

 

________________________________

From: users-bounces_at_[hidden] [mailto:users-bounces_at_[hidden]] On
Behalf Of Iannetti, Anthony C. (GRC-RTB0)
Sent: Monday, February 09, 2009 6:10 AM
To: Open MPI Users
Subject: [OMPI users] Linux Itanium Configure and Make Logs for 1.2.8

 

I have attached the ./configure and make all output for version 1.2.8 as
directed in the Open MPI "Getting Help" section. Hopefully, this will
guide us on what is going on with the 1.3 assembler code.

 

Tony

 

Anthony C. Iannetti, P.E.

NASA Glenn Research Center

Aeropropulsion Division, Combustion Branch

21000 Brookpark Road, MS 5-10

Cleveland, OH 44135

phone: (216)433-5586

email: Anthony.C.Iannetti_at_[hidden]

 

Please note: All opinions expressed in this message are my own and NOT
of NASA. Only the NASA Administrator can speak on behalf of NASA.