Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] open-mpi ssh hostname problem
From: Bernhard Knapp (bernhard.knapp_at_[hidden])
Date: 2009-02-09 04:37:03


Thanks for the hint. If I set the hostname via the console command
hostname it does not work but if I use the GUI instead to change the
name it works fine (problem solved). May be there are more commands
necessary than simply hostname to make it running on the console?
Bernhard ------------------------------ Message: 4 Date: Fri, 6 Feb 2009
17:48:44 -0500 From: Jeff Squyres <jsquyres_at_[hidden]> Subject: Re:
[OMPI users] open-mpi ssh hostname problem To: Open MPI Users
<users_at_[hidden]> Message-ID:
<340A96DD-6CD3-4BEC-BCBD-92AA2CFDD46C_at_[hidden]> Content-Type:
text/plain; charset=US-ASCII; format=flowed; delsp=yes I'm not quite
sure what you did here; did you set the IP address and hostname to
something that is resolvable via gethostbyname()? E.g., does the
hostname exist in DNS or in /etc/hosts and match the IP address that you
set? On Feb 6, 2009, at 6:18 AM, Bernhard Knapp wrote:

>> Dear users
>>
>> I am using the parallel software Gromacs on Fedora8 nodes. I
>> installed the software and run it without problems but thereafter I
>> moved the node to our server-room and did the following:
>> - set ip adress, subnetmask and gateway
>> - changed the ssh port in /etc/ssh/sshd_config since we use port
>> forwarding on our router and /usr/sbin/semanage port -a -t
>> inetd_child_port_t -p tcp 5101
>> - changed the firewall settings to additionally allow the new port
>> - changed the hostname via hostname command
>>
>> Then I started exactly the same simulation (same command, same data)
>> as before (before the network configuration) and it comes up with
>> the following error:
>>
>>
>> ssh: quoVadis01: Name or service not known
>> --------------------------------------------------------------------------
>> A daemon (pid 5039) died unexpectedly with status 255 while attempting
>> to launch so we are aborting.
>>
>> There may be more information reported by the environment (see above).
>>
>> This may be because the daemon was unable to find all the needed
>> shared
>> libraries on the remote node. You may set your LD_LIBRARY_PATH to
>> have the
>> location of the shared libraries on the remote nodes and this will
>> automatically be forwarded to the remote nodes.
>> --------------------------------------------------------------------------
>> --------------------------------------------------------------------------
>> mpirun noticed that the job aborted, but has no info as to the process
>> that caused that situation.
>> --------------------------------------------------------------------------
>> mpirun: clean termination accomplished
>>
>>
>> Currently the simulation is only running in parallel on the local 4
>> cores and not using the network at all.
>>
>> Why is it a problem for open-mpi to change the hostname from
>> "localhost" to "quoVadis01"? If i change the hostname back it works
>> again. How can I make open-mpi running using a hostname different to
>> localhost. Simply to reinstall mpi after changing the hostname does
>> not help.
>>
>> cheers
>> Bernhard
>>
>>
>>
>>
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>

-- Jeff Squyres Cisco Systems