Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] OpenMPI hangs across multiple nodes.
From: Lenny Verkhovsky (lenny.verkhovsky_at_[hidden])
Date: 2009-02-04 08:37:44


what kind of communication between nodes do you have - tcp, openib (
IB/IWARP ) ?
you can try

mpirun -np 4 -host node1,node2 -mca btl tcp,self random

On Wed, Feb 4, 2009 at 1:21 AM, Ralph Castain <rhc_at_[hidden]> wrote:
> Could you tell us which version of OpenMPI you are using, and how it was
> configured?
>
> Did you install the OMPI libraries and binaries on both nodes? Are they in
> the same absolute path locations?
>
> Thanks
> Ralph
>
>
> On Feb 3, 2009, at 3:46 PM, Robertson Burgess wrote:
>
>> Dear users,
>> I am quite new to OpenMPI, I have compiled it on two nodes, each node with
>> 8 CPU cores. The two nodes are identical. The code I am using works in
>> parallel across the 8 cores on a single node. However, whenever I try to run
>> across both nodes, OpenMPI simply hangs. There is no output whatsoever, when
>> I run it in background, outputting to a log file, the log file is always
>> empty. The cores do not appear to be doing anything at all, either on the
>> host node or on the remote node. This happens whether I am running my code,
>> or even if I when I tell it to run a process that doesn't even exist, for
>> instance
>>
>> mpirun -np 4 -host node1,node2 random
>>
>> Simply results in the terminal hanging, so all I can do is close the
>> terminal and open up a new one.
>>
>> mpirun -np 4 -host node1,node2 random >& log.log &
>>
>> simply produces and empty log.log file
>>
>> I am running Redhat Linux on the systems, and compiled OpenMPI with the
>> Intel Compilers 10.1. As I've said, it works fine on one node. I have set up
>> both nodes such that they can log into each other via ssh without the need
>> for a password, and I have altered my .bashrc file so the PATH and
>> LD_LIBRARY_PATH include the appropriate folders.
>> I have looked through the FAQ and mailing lists, but I was unable to find
>> anything that really matched my problem. Any help would be greatly
>> appreciated.
>>
>> Sincerely,
>> Robertson Burgess
>> University of Newcastle
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>