Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] Openmpi 1.3 problems with libtool-ltdl on CentOS 4 and 5
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2009-01-31 08:09:11


On Jan 30, 2009, at 4:25 PM, Roy Dragseth wrote:

> I'm not very familiar with the workings of ltdl, I got this from one
> of our
> users. Would you suggest that if one use openmpi 1.3 and ltdl you
> should not
> explicitly link with -lltdl? At least this seems to work correctly
> with the
> example I posted. That is, I can link the program without specifying
> -lltdl so
> the symbol seems to resolve to something in the openmpi libraries
> and the
> example runs without crashing.

Yes, that is what I would recommend.

I note that the Libtool v2.2.6a docs explicitly describe this problem
and say "don't do that" (see section 11.6). But I agree that it's a
less-than-optimal solution for OMPI users because you shouldn't need
to know/care that Open MPI embeds its own copy of libltdl. I have
just posted to the libtool-bug mailing list to see if they would
consider a configure option to add a prefix to OMPI's internal libltdl
symbols, thereby preventing clashes like this. Let's see what they say.

     http://lists.gnu.org/archive/html/bug-libtool/2009-01/msg00032.html

-- 
Jeff Squyres
Cisco Systems