Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Openmpi 1.3 problems with libtool-ltdl on CentOS 4 and 5
From: Roy Dragseth (roy.dragseth_at_[hidden])
Date: 2009-01-30 16:25:28


On Friday 23 January 2009 15:31:59 Jeff Squyres wrote:
> Ew. Yes, I can see this being a problem.
>
> I'm guessing that the real issue is that OMPI embeds the libltdl from
> LT 2.2.6a inside libopen_pal (one of the internal OMPI libraries).
> Waving my hands a bit, but it's not hard to imagine some sort of clash
> is going on between the -lltdl you added to the command line and the
> libltdl that is embedded in OMPI's libraries.
>
> Can you verify that this is what is happening?

Hi, sorry for the delay.

I'm not very familiar with the workings of ltdl, I got this from one of our
users. Would you suggest that if one use openmpi 1.3 and ltdl you should not
explicitly link with -lltdl? At least this seems to work correctly with the
example I posted. That is, I can link the program without specifying -lltdl so
the symbol seems to resolve to something in the openmpi libraries and the
example runs without crashing.

Regards,
r.

-- 
  The Computer Center, University of Tromsø, N-9037 TROMSØ Norway.
              phone:+47 77 64 41 07, fax:+47 77 64 41 00
     Roy Dragseth, Team Leader, High Performance Computing
         Direct call: +47 77 64 62 56. email: roy.dragseth_at_[hidden]