Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] open-mpi_1.3, intel ompi_info compiling errors
From: Ralph Castain (rhc_at_[hidden])
Date: 2009-01-26 16:07:10


Strange. We have successfully built 1.3 using Intel 11.0 and earlier
versions on RHEL5 and Fedora 9 (only 11.0, of course).

Can you send your configure? Perhaps there is something different there.

On Jan 26, 2009, at 1:44 PM, Scot Breitenfeld wrote:

> Hi, I'm trying to compile from source open-mpi-1.3r20295 on a suse
> linux
> 64-bit system (I also tried a 32-bit linux system, same problem). I'm
> using Intel compilers version 11.0 (and 10.1) for fortran, C/C++
> (ifort, icc, icpc). The configure script completes with no errors, but
> when I do make it fails when trying to compile output.cc with the
> error:
>
> make[2]: Entering directory `/mnt/hdf/brtnfld/packages/jam/
> build_intel/ompi/tools/ompi_info'
> depbase=`echo components.o | sed 's|[^/]*$|.deps/&|;s|\.o$||'`;\
> /usr/hdf/bin/icpc -DHAVE_CONFIG_H -I. -I../../../../
> openmpi-1.3/ompi/tools/ompi_info -I../../../opal/include -I../../../
> orte/include -I../../../ompi/include -I../../../opal/mca/paffinity/
> linux/plpa/src/libplpa -DOMPI_CONFIGURE_USER="\"brtnfld\"" -
> DOMPI_CONFIGURE_HOST="\"jam\"" -DOMPI_CONFIGURE_DATE="\"Mon Jan 26
> 14:12:54 CST 2009\"" -DOMPI_BUILD_USER="\"$USER\"" -
> DOMPI_BUILD_HOST="\"`hostname`\"" -DOMPI_BUILD_DATE="\"`date`\"" -
> DOMPI_BUILD_CFLAGS="\"-O3 -DNDEBUG -finline-functions -fno-strict-
> aliasing -restrict -pthread -fvisibility=hidden\"" -
> DOMPI_BUILD_CPPFLAGS="\"-I../../../../openmpi-1.3 -I../../.. -
> I../../../../openmpi-1.3/opal/include -I../../../../openmpi-1.3/orte/
> include -I../../../../openmpi-1.3/ompi/include \"" -
> DOMPI_BUILD_CXXFLAGS="\"-O3 -DNDEBUG -finline-functions -pthread\"" -
> DOMPI_BUILD_CXXCPPFLAGS="\"-I../../../../openmpi-1.3 -I../../.. -
> I../../../../openmpi-1.3/opal/include -I../../../../openmpi-1.3/orte/
> include -I../../../../openmpi-1.3/ompi/include \"" -
> DOMPI_BUILD_FFLAGS="\"\"" -DOMPI_BUILD_FCFLAGS="\"\"" -
> DOMPI_BUILD_LDFLAGS="\"-export-dynamic \"" -DOMPI_BUILD_LIBS="\"-
> lnsl -lutil \"" -DOMPI_CC_ABSOLUTE="\"\"" -
> DOMPI_CXX_ABSOLUTE="\"\"" -DOMPI_F77_ABSOLUTE="\"\"" -
> DOMPI_F90_ABSOLUTE="\"\"" -DOMPI_F90_BUILD_SIZE="\"small\"" -
> I../../../../openmpi-1.3 -I../../.. -I../../../../openmpi-1.3/opal/
> include -I../../../../openmpi-1.3/orte/include -I../../../../
> openmpi-1.3/ompi/include -O3 -DNDEBUG -finline-functions -pthread
> -MT components.o -MD -MP -MF $depbase.Tpo -c -o
> components.o ../../../../openmpi-1.3/ompi/tools/ompi_info/
> components.cc &&\
> mv -f $depbase.Tpo $depbase.Po
> icpc: command line error: invalid argument for option '-fvisibility'
> make[2]: *** [components.o] Error 1
> make[2]: Leaving directory `/mnt/hdf/brtnfld/packages/jam/
> build_intel/ompi/tools/ompi_info'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/mnt/hdf/brtnfld/packages/jam/
> build_intel/ompi'
> make: *** [all-recursive] Error 1
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users