Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] MPI_THREAD_MULTIPLE not provided
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2009-01-26 14:31:40


MPI_THREAD_MULTIPLE support in the 1.2 series is unfortunately pretty
broken/non-existent.

The v1.3 series has MPI point-to-point support for several networks
with MPI_THREAD_MULTIPLE; check the README file.

On Jan 26, 2009, at 9:21 AM, Ali Copey wrote:

> Hi,
>
> I'm trying to get multiple thread running, and have openMPI 1.2.8
> compiled with threading enabled:
>
> xxx_at_xxx:/usr/lib$ ompi_info | grep Thread
> Thread support: posix (mpi: yes, progress: no)
>
> however, when I attempt to get MPI_THREAD_MULTIPLE, ...FUNNELED
> or ...SERIALIZED I am returned MPI_THREAD_SINGLE (code fragment
> follows):
>
> int provided = MPI::Init_thread(MPI_THREAD_MULTIPLE);
>
> switch(provided)
> {
> case MPI_THREAD_SINGLE: cout << "MPI_THREAD_SINGLE"; break;
> case MPI_THREAD_FUNNELED: cout << "MPI_THREAD_FUNNELED"; break;
> case MPI_THREAD_SERIALIZED: cout << "MPI_THREAD_SERIALIZED";
> break;
> case MPI_THREAD_MULTIPLE: cout << "MPI_THREAD_MULTIPLE"; break;
> }
>
> Am I missing a compiler flag somewhere?
>
> System:
> Linux xxx 2.6.26-1-amd64 #1 SMP Thu Oct 9 14:16:53 UTC 2008 x86_64
> GNU/Linux
>
> Thanks for any help,
> Alex
>
>
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
Cisco Systems