Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] MCA base component file not found
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2009-01-23 06:44:07


This sounds like you installed OMPI v1.3 over your existing OMPI v1.2
installation.

Note that there are several plugins in the v1.2 series that
disappeared in the v1.3 series (i.e., those plugins are either no
longer supported or transmorgified into new plugins in v1.3; the
latter is the most common case). It is best to remove your old v1.2
installation before installing v1.3.

But if you're no longer able to do that, remove each of the files
listed below (those are the v1.2 plugins that did not carry forward to
v1.3), and that should be sufficient.

On Jan 23, 2009, at 5:43 AM, Yongqi Sun wrote:

> Hello,
>
> Open MPI 1.3 is giving me the following warnigns no matter what
> executables I was launching, even a helloworld program:
>
> ======================================
> openmpi-1.3/examples$ mpiexec -np 2 hello
> [MyPC:06046] mca: base: component_find: unable to open /usr/local/
> lib/openmpi/mca_ras_dash_host: file not found (ignored)
> [MyPC:06046] mca: base: component_find: unable to open /usr/local/
> lib/openmpi/mca_ras_gridengine: file not found (ignored)
> [MyPC:06046] mca: base: component_find: unable to open /usr/local/
> lib/openmpi/mca_ras_localhost: file not found (ignored)
> [MyPC:06046] mca: base: component_find: unable to open /usr/local/
> lib/openmpi/mca_errmgr_hnp: file not found (ignored)
> [MyPC:06046] mca: base: component_find: unable to open /usr/local/
> lib/openmpi/mca_errmgr_orted: file not found (ignored)
> [MyPC:06046] mca: base: component_find: unable to open /usr/local/
> lib/openmpi/mca_errmgr_proxy: file not fo! und (ignored)
> [MyPC:06046] mca: base: component_find: unable to open /usr/local/
> lib/openmpi/mca_iof_proxy: file not found (ignored)
> [MyPC:06046] mca: base: component_find: unable to open /usr/local/
> lib/openmpi/mca_iof_svc: file not found (ignored)
> [MyPC:06052] mca: base: component_find: unable to open /usr/local/
> lib/openmpi/mca_iof_proxy: file not found (ignored)
> [MyPC:06052] mca: base: component_find: unable to open /usr/local/
> lib/openmpi/mca_iof_svc: file not found (ignored)
> Hello, world, I am 0 of 2
> Hello, world, I am 1 of 2
> ======================================
>
> How can I install these How can I suppress these warnings? I haven't
> found any instruction about this in FAQ.
>
> I installed Open MPI version 1.3 on my Linux multicore desktop, into
> the same folder with version 1.2.8. I installed by the simpliest
> configuration:
>
> $ configure --prefix=/usr/local
> $ make all install
>
> Thanks a lot.
>
> Sun, Yongqi
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
Cisco Systems