Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Problem compiling open mpi 1.3 with sunstudio12 express
From: Olivier Marsden (Olivier.Marsden_at_[hidden])
Date: 2009-01-21 04:53:26


>
> - Check that /opt/mpi_sun and /opt/mpi_gfortran* are actually distinct
> subdirectories; there's no hidden sym/hard links in there somewhere
> (where directories and/or individual files might accidentally be
> pointing to the other tree)
>

no hidden links in the directories

> - does "env | grep mpi_" show anything interesting / revealing? What
> is your LD_LIBRARY_PATH set to?
>
Nothing in env | grep mpi, and for the purposes of building,
LD_LIBRARY_PATH is set to
 /opt/sun/express/sunstudioceres/lib/:/opt/mpi_sun/lib:xxx
where xxx is, among other things, the other mpi installations.
This lead me to find a problem, but which seems to be more related to my
linux configuration than openmpi:
I tried redefining ld_library_path to point just to sun, and everything
works correctly.
Putting my previous paths back into the variable leads to erroneous
behaviour, with ldd indicating that mpif90
is linked to libraries in the gfortran tree.
I thought that ld looked for libraries in folders in the order that the
folders are given in ld_library_path, and so
having mpi_sun as the first folder would suffice for its libraries to be
used; is that where I was wrong?
Sorry for the trouble, in any case redefining the ld_library_path to
remove all references to other installations works.
Looks like I'll have to swot up on my linker configuration knowledge!
Thanks alot for your time,

Olivier Marsden