Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Problem compiling open mpi 1.3 with sunstudio12 express
From: Douglas Guptill (douglas.guptill_at_[hidden])
Date: 2009-01-19 13:00:36


When I use the Intel compilers, I have to add to my PATH and
LD_LIBRARY_PATH before using "mpif90". I wonder if this needs to be
done in your case?

Douglas.

On Mon, Jan 19, 2009 at 05:49:53PM +0100, Olivier Marsden wrote:
> Hello,
>
> I'm trying to compile ompi 1.3rc7 with the sun studio express comilers.
>
> I'm using the following configure command:
>
> CC=/opt/sun/express/sunstudioceres/bin/cc
> CXX=/opt/sun/express/sunstudioceres/bin/CC
> F77=/opt/sun/express/sunstudioceres/bin/f77
> FC=/opt/sun/express/sunstudioceres/bin/f90 ./configure
> --prefix=/opt/mpi_sun --enable-heterogeneous --enable-shared
> --enable-mpi-f90 --with-mpi-f90-size=small --disable-mpi-threads
> --disable-progress-threads --disable-debug --without-udapl
> --disable-io-romio
>
> The build and install execute correctly. However, I get the following
> when trying to use mpif90:
> >> /opt/mpi_sun/bin/mpif90
> gfortran: no input files
>
> My /opt/mpi_sun/share/openmpi/mpif90-wrapper-data.txt file appears to
> my layman eye to be correct, but just
> in case, its contents is the following:
>
> project=Open MPI
> project_short=OMPI
> version=1.3rc7
> language=Fortran 90
> compiler_env=FC
> compiler_flags_env=FCFLAGS
> compiler=/opt/sun/express/sunstudioceres/bin/f90
> module_option=-M
> extra_includes=
> preprocessor_flags=
> compiler_flags=
> linker_flags=
> libs=-lmpi_f90 -lmpi_f77 -lmpi -lopen-rte -lopen-pal -ldl
> -Wl,--export-dynamic -lnsl -lutil -lm -ldl
> required_file=
> includedir=${includedir}
> libdir=${libdir}
>
>
> Can anyone see why gfortran is being used? (the config.log says that sun
> f90 is used )
>
> Thanks,
>
> Olivier