Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Open MPI and mpi-defaults
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2009-01-07 06:29:07


It sounds like we need an alpha implementation (and mips?) of our
assembly code...

I don't think anyone in the community currently supports either of
these platforms, unfortunately.

On Jan 6, 2009, at 4:33 PM, Adam C Powell IV wrote:

> On Tue, 2009-01-06 at 12:25 -0600, Dirk Eddelbuettel wrote:
>> I noticed that openmpi is now owner of a FTFBS against mpi-defaults
>> because
>> the latter wants the former which is missing on Alpha.
>
> I'm sorry, I was supposed to let you know about this, as this openmpi
> failure is keeping arpack++ out of Lenny. The real problem is that
> openmpi is FTBFS on alpha, see below.
>
>> Can anybody dive in there and sort this out?
>
> The openmpi buildd log on alpha [1] ends with:
> [1] http://buildd.debian.org/fetch.cgi?pkg=openmpi;ver=1.2.8-3;arch=alpha;stamp=1225663211
>
> /bin/sh ../../../libtool --tag=CXX --mode=link g++ -DNDEBUG -g -
> O2 -finline-functions -pthread -export-dynamic -o ompi_info
> components.o ompi_info.o output.o param.o version.o ../../../ompi/
> libmpi.la -lnsl -lutil -lm
> libtool: link: g++ -DNDEBUG -g -O2 -finline-functions -pthread -
> o .libs/ompi_info components.o ompi_info.o output.o param.o
> version.o -Wl,--export-dynamic ../../../ompi/.libs/libmpi.so /usr/
> lib/libibverbs.so -lpthread -lrt /build/buildd/openmpi-1.2.8/build/
> static/orte/.libs/libopen-rte.so /build/buildd/openmpi-1.2.8/build/
> static/opal/.libs/libopen-pal.so -ldl -lnsl -lutil -lm -pthread -Wl,-
> rpath -Wl,/usr/lib/openmpi/lib
> ../../../ompi/.libs/libmpi.so: undefined reference to
> `opal_sys_timer_get_cycles'
> collect2: ld returned 1 exit status
> make[3]: *** [ompi_info] Error 1
> make[3]: Leaving directory `/build/buildd/openmpi-1.2.8/build/static/
> ompi/tools/ompi_info'
>
> Earlier on we have:
>
> make[3]: Entering directory `/build/buildd/openmpi-1.2.8/build/basic/
> ompi/mca/btl/openib'
> ...
> libtool: compile: gcc -DHAVE_CONFIG_H -I. -I../../../../opal/
> include -I../../../../orte/include -I../../../../ompi/include -
> I../../../../../../ompi/mca/btl/openib -DPKGDATADIR=\"/usr/share/
> openmpi\" -I../../../../../.. -I../../../.. -I../../../../../../opal/
> include -I../../../../../../orte/include -I../../../../../../ompi/
> include -DNDEBUG -Wall -g -O2 -finline-functions -fno-strict-
> aliasing -pthread -MT btl_openib_component.lo -MD -MP -MF .deps/
> btl_openib_component.Tpo -c ../../../../../../ompi/mca/btl/openib/
> btl_openib_component.c -fPIC -DPIC -o .libs/btl_openib_component.o
> ../../../../../../ompi/mca/btl/openib/btl_openib_component.c: In
> function 'btl_openib_component_init':
> ../../../../../../ompi/mca/btl/openib/btl_openib_component.c:666:
> warning: implicit declaration of function 'opal_sys_timer_get_cycles'
>
> Okay, found it. This function is inline assembly in timer.h, which
> exists in opal/sys/amd64, ia32, ia64, powerpc and sparcv9 but not
> alpha,
> mips, sparc or win32. That said, timer.h in opal/sys has:
>
> #ifndef OPAL_HAVE_SYS_TIMER_GET_CYCLES
> #define OPAL_HAVE_SYS_TIMER_GET_CYCLES 0
>
> which somehow is working on sparc (no reference to this function in
> the
> buildd log) but not alpha. (On mips, there are a bunch of assembler
> errors of the form "opcode not supported on this processor".)
>
> That's about what I have time for now. Don't worry about mpi-
> defaults,
> it's not trying to get into Lenny; but we should worry about OpenMPI
> not
> building on alpha. Does anyone on users_at_[hidden] have any ideas?
>
> -Adam
> --
> GPG fingerprint: D54D 1AEE B11C CE9B A02B C5DD 526F 01E8 564E E4B6
>
> Engineering consulting with open source tools
> http://www.opennovation.com/
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
Cisco Systems