Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] MCA parameter
From: Ralph Castain (rhc_at_[hidden])
Date: 2008-12-08 08:39:47


There are multiple ways to set MCA parameters - you can checkout the
FAQ to see all of them:

http://www.open-mpi.org/faq/?category=tuning#setting-mca-params

In your immediate case, just add -mca
btl_openib_warn_default_gid_prefix 0 to your cmd line.

Ralph

On Dec 8, 2008, at 1:49 AM, Yasmine Yacoub wrote:

> Good morning,
>
> I have explain my problem lat time and still I haven't receive any
> response.
> ok, my problem is that after installing pwscf and running one scf
> example, I got the output but with this warning message :
> WARNING: There are more than one active ports on host
> 'stallo-2.local', but the
> default subnet GID prefix was detected on more than one of these
> ports. If these ports are connected to different physical IB
> networks, this configuration will fail in Open MPI. This version of
> Open MPI requires that every physically separate IB subnet that is
> used between connected MPI processes must have different subnet ID
> values.
>
> Please see this FAQ entry for more details:
>
> http://www.open-mpi.org/faq/?category=openfabrics#ofa-default-subnet-gid
>
> NOTE: You can turn off this warning by setting the MCA parameter
> btl_openib_warn_default_gid_prefix to 0.
>
> So, please how can I turn off this warning? I have already tried to
> follow the steps indicated in the link above but it doesn't work.
> what is exactly the command I have to use?
>
> Thanks,
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users