Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] trouble using --mca mpi_yield_when_idle 1
From: Douglas Guptill (douglas.guptill_at_[hidden])
Date: 2008-12-06 19:38:21


Hi:

I am using openmpi-1.2.8 to run a 2 processor job on an Intel
Quad-core cpu. Opsys is Debian etch. I am reaonably sure that, most
of the time, one process is waiting for results from the other. The
code is fortran 90, and uses mpi_send and mpi_recv. Yet
"gnome-system-monitor" shows 2 cpus at 100%.

So I read, and re-read, the FAQs, and found the mpi_yield_when_idle
flag, and tried it:

 mpirun --host localhost,localhost,localhost,localhost --mca btl sm,self --mca mpi_yield_when_idle 1 --byslot -np 2 /home/dguptill/software/sopale_nested_2008-10-24/bin/sopale_nested_openmpi-intel-noopt

And still get, for each run, two cpus are at 100%.

My goal is to get the system to a minimum usage state, where only one
cpu is being used, if one process is waiting for results from the
other.

Can anyone suggest if this is possible, and if so, how?

Thanks,
Douglas.

-- 
  Douglas Guptill                       
  Research Assistant, LSC 4640          email: douglas.guptill_at_[hidden]
  Oceanography Department               fax:   902-494-3877
  Dalhousie University
  Halifax, NS, B3H 4J1, Canada