Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] how to get openMPI working, someone help me.
From: Venu Gopal (venudxb_at_[hidden])
Date: 2008-11-18 11:15:44


Well, the version number 8.04.1 was the version number of the Ubuntu JeOS.

Very similar to the Ubuntu Server but with a optimized kernel for VmWare.

see the link here.
http://cdimage.ubuntu.com/jeos/releases/8.04.1/release/

well i searched the repositories, but could not find anything for a few
days. so i thought that it has to be installed using the tar.gz file.

thanks for pointing out that is there in the repos.

Well i am actually waiting for the Debian Lenny release. Once my testing on
VmWare is over. My plan is to use real machines. And definitely it will be
Lenny.

Thanks

Regards

Venu Gopal

On Tue, Nov 18, 2008 at 5:24 PM, Dirk Eddelbuettel <edd_at_[hidden]> wrote:

>
> On 18 November 2008 at 17:06, Venu Gopal wrote:
> | Hello,
> |
> | I am new into this mailing list, and am trying to install openMPI on
> Ubuntu
> | 8.0.4.1
>
> (That's not an existing version number.)
>
> | Basically my idea is to build a beowulf. Well right now i even dont have
> | lots of PC's for this purpose.
> |
> | So I am planning to first use virtual machines on VmWare. I have
> installed
> | around four Virtual machines on my PC. And all of them can talk to each
> | other. I mean they are all networked together without any firewalls in
> | between.
> |
> | I downloaded openmpi-1.2.8.tar.gz, extracted it and executed the
> configure
> | script file.
> |
> | This gave me lots of errors, and didnt suceed. How do I get this working
> | now.
>
> Open MPi is packaged for Debian and hence part of Ubuntu. So just do:
>
> $ sudo apt-get install libopenmpi1 linopenmpi-dev openmpi-bin openmpi-doc
>
> In Ubuntu 8.10, this gives you Open MPI 1.2.7. In Ubuntu 8.4, you're at a
> slightly older version so I suggest upgrading.
>
> In case you really want 1.2.8, by far the easiest way (and also most
> general)
> is to just grab the Debian source from 'Debian unstable' and rebuild on
> your
> system to match your libraries. That can be quasi-automated, see 'apt-get
> source' and use google as this is getting off-topic for this list.
>
> Hope this helps,
>
> Dirk
> (one of severap Debian Open MPI maintainers)
>
> --
> Three out of two people have difficulties with fractions.
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>