Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Trouble with OpenMPI and Intel 10.1 compilers
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2008-11-11 15:12:59


On Nov 11, 2008, at 2:54 PM, Ray Muno wrote:

>> See http://www.open-mpi.org/faq/?category=mpi-apps#override-wrappers-after-v1.0
>> .
>
> OK, that tells me lots of things ;-)
>
> Should I be running configure with --with-wrapper-cflags,
> --with-wrapper-fflags etc,
>
> set to include
>
> -i_dynamic

If you want to, sure. As a guideline, the wrapper compilers put in
the minimum number of flags to get the job done -- any other flags are
a local policy decision (and we wouldn't presume to make those for you).

FWIW, the warning is harmless, but I can see how you wouldn't want
users to see it / be alarmed by it.

-- 
Jeff Squyres
Cisco Systems