Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] Trouble with OpenMPI and Intel 10.1 compilers
From: Ray Muno (muno_at_[hidden])
Date: 2008-11-11 13:18:13


We have recently installed the Intel 10,1 compiler suite on our cluster.

I built OpenMPI (1.2.7 and 1.2.8) with

./configure CC=icc CXX=icpc F77=ifort FC=ifort

It configures, builds and installs.

However, the MPI compiler drivers (mpicc, mpif90, etc) fail immediately
with error of the sort

mpif90: error while loading shared libraries: libimf.so: cannot open
shared object file: No such file or directory

I updated the LD_LIBRARY_PATH to point to the directories that contain
the installed copies of libimf.so. (this is not something I have not had
to do for other compiler/OpenMpi combinations)

At that point, the program will compile but I get warnings like:

[muno_at_titan ~]$ mpif90 test.f

/share/apps/Intel/fce/10.1.018/lib/libimf.so: warning: warning:
feupdateenv is not implemented and will always fail

In a google search, I found a reference to this in the OpenMPI lists.
When I follow the link, it is a different thread. Searching the OpenMPI
lists from the web page does not find any matches. Strange.

I found some references to this at some other sites using OpenMPI on
clusters and they said to use

-i_dynamic

on the compile line.

This removes the warning.

Is there something I should be doing at OpenMPI configure time to take
care of these issues?

--
Ray Muno
University of Minnesota
Aerospace Engineering