Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] ompi_info hangs
From: Robert Kubrick (robertkubrick_at_[hidden])
Date: 2008-11-08 17:31:40


George, I have warning when running under debugger 'Lowest section in
system-supplied DSO at 0xffffe000 is .hash at ffffe0b4'
The program hangs in _int_malloc():

(gdb) run
Starting program: /opt/openmpi-1.2.7/bin/ompi_info
warning: Lowest section in system-supplied DSO at 0xffffe000 is .hash
at ffffe0b4
[Thread debugging using libthread_db enabled]
[New Thread 0xf7b7d6d0 (LWP 16621)]
1.2.7

Program received signal SIGINT, Interrupt.
[Switching to Thread 0xf7b7d6d0 (LWP 16621)]
0xf7e5267e in _int_malloc () from /opt/openmpi/lib/libopen-pal.so.0
(gdb) where
#0 0xf7e5267e in _int_malloc () from /opt/openmpi/lib/libopen-pal.so.0
#1 0xf7e544e1 in malloc () from /opt/openmpi/lib/libopen-pal.so.0
#2 0xf7db46c7 in operator new () from /usr/lib/libstdc++.so.6
#3 0xf7d8e121 in std::string::_Rep::_S_create () from /usr/lib/
libstdc++.so.6
#4 0xf7d8ee18 in std::string::_Rep::_M_clone () from /usr/lib/libstdc
++.so.6
#5 0xf7d8fac8 in std::string::reserve () from /usr/lib/libstdc++.so.6
#6 0xf7d8ff6a in std::string::append () from /usr/lib/libstdc++.so.6
#7 0x08054f30 in ompi_info::out ()
#8 0x08062a33 in ompi_info::show_ompi_version ()
#9 0x080533a0 in main ()

On Nov 8, 2008, at 12:33 PM, George Bosilca wrote:

> I think we had a similar problem on the past. It has something to
> do with the atomics on this architecture.
>
> I don't have access to such an architecture. Can you provide us a
> stack trace when this happens ?
>
> Thanks,
> george.
>
> On Nov 8, 2008, at 12:14 PM, Robert Kubrick wrote:
>
>> I am having problems building OMPI 1.2.7 on an Intel Xeon quad-
>> core 64 bits server. The compilation completes but ompi_info hangs
>> after printing the OMPI version:
>>
>> # ompi_info
>> 1.2.7
>>
>> I tried to run a few mpi applications on this same install and
>> they do work fine. What can cause ompi_info to hang?
>>
>>
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users