Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Problems installing in Cygwin - Problem with GCC 3.4.4
From: Terry Frankcombe (terry_at_[hidden])
Date: 2008-11-04 04:23:37


> *** Fortran 90/95 compiler
> checking whether we are using the GNU Fortran compiler... yes
> checking whether g95 accepts -g... yes
> checking if Fortran compiler works... yes
> checking whether g95 and g95 compilers are compatible... no
> configure: WARNING: *** Fortran 77 and Fortran 90 compilers are not
> link compatible
> configure: WARNING: *** Disabling MPI Fortran 90/95 bindings

OK, for that one I think you need to dig into config.log and see exactly
what's failing and why.

I can't speak for the developers, but it seems slightly concerning that
configure thinks it's using "the GNU Fortran compiler". I feel sure the
GNU people would object to g95 being called that.