Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Fwd: Problems installing in Cygwin
From: George Bosilca (bosilca_at_[hidden])
Date: 2008-10-31 16:28:57


Gustavo,

I guess that if you disable the vt contrib package, this is take you
one step further :) Hopefully at the end of the compile stage ... and
at the beginning of troubles with running the cygwin parallel
applications ...

Meanwhile, there is a special option to disable contrib packages.
Please add --enable-contrib-no-build=vt to your configure line and
this should do the trick.

   george.

On Oct 31, 2008, at 3:20 PM, Gustavo Seabra wrote:

> On Thu, Oct 30, 2008 at 9:04 AM, George Bosilca wrote:
>
> Hi George,
>
> I'm sorry for taking too long to respond. As you mentioned, config
> takes a veeeeeeery long time in cygwin, and then the install itself
> takes many ties that :-(
>
>> As Jeff mentioned this component is not required on Windows. You
>> can disable
>> it completely in Open MPI and everything will continue to work
>> correctly.
>> Please add --enable-mca-no-build=memory_mallopt o maybe the more
>> generic (as
>> there is no need for any memory manager on Windows
>> --enable-mca-no-build=memory.
>
> Tried, doesn't quite work:
>
> If I configure with "--enable-mca-no-build=memory", the config dies
> with:
>
> *** Final output
> configure: error: conditional "OMPI_WANT_EXTERNAL_PTMALLOC2" was
> never defined.
> Usually this means the macro was only invoked conditionally.
>
> Now, if i try with "--enable-mca-no-build=memory_mallopt", the
> configuration script runs just fine, but the compilation dies when
> compiling "mca/paffinity/windows":
>
> libtool: compile: gcc -DHAVE_CONFIG_H -I.
> -I../../../../opal/include -I../../../../orte/include -I../../../..
> /ompi/include
> -I../../../../opal/mca/paffinity/linux/plpa/src/libplpa -I../../../..
> -D_REENTRANT -O3
> -DNDEBUG -finline-functions -fno-strict-aliasing -MT
> paffinity_windows_module.lo -MD -MP -MF
> .deps/paffinity_windows_module.Tpo -c paffinity_windows_module.c
> -DDLL_EXPORT -DPIC -o
> .libs/paffinity_windows_module.o
> paffinity_windows_module.c:44: error: parse error before "sys_info"
>
> [... and then a bunch of messages after that, all related to
> paffinity_windows_module.c, which...]
> [... I think are all related to this first one...]
>
> Finally, I thought that I can live without processor affinity or even
> memory affinity, so I tried using
> " --enable-mca-no-build=memory_mallopt,maffinity,paffinity", and the
> configuration went all smoothly. The compilation... You guessed, died
> again. But this time it was something that had bit me before:
> RTLD_NEXT, which is required by one contributed package (vt). (See my
> previous message to Jeff and the list.)
>
> My next attempt will be to remove this package, and see how far I can
> get... But I'm getting there :-)
>
>> It is possible to have a native version of Open MPI on Windows.
>> There are
>> two ways to achieve this. First, install SFU, and compile there. It
>> worked
>> last time I checked, but it's not the solution I prefer. Second,
>> you can
>> install the express version of the Microsoft Visual Studio (which
>> is free),
>> and set your PATH, LIB and INCLUDE correctly to point to the
>> installation,
>> and then you can use the cl compiler to build Open MPI even on
>> Windows.
>
> That is true, but it seems more complicated for the regular user than
> installing OpenMPI (assuming I can figure out the correct combination
> of options) Also, our program is actually made for unix, and as a
> convenience it *can* be installed in Cygwin, but I'm not sure how it
> would work with a native Windows OpenMPI.
>
> Anyways... I fell like I'm getting closer.. Will keep trying during
> the weekend.
>
> Thanks a lot for all the help! (That goes to Jeff too)
>
> Cheers,
> Gustavo.
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users



  • application/pkcs7-signature attachment: smime.p7s