Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Fwd: Problems installing in Cygwin
From: George Bosilca (bosilca_at_[hidden])
Date: 2008-10-28 09:06:40


It is complaining about a missing file. This is a file from the Open
MPI distribution, I wonder how it can be missing. Can you verify that
the file opal/mca/timer/windows/timer_windows_component.h is there ?

   Thanks,
     george.

On Oct 27, 2008, at 4:52 PM, Jeff Squyres wrote:

> Sorry for the lack of reply; several of us were at the MPI Forum
> meeting last week, and although I can't speak for everyone else, I
> know that I always fall [way] behind on e-mail when I travel. :-\
>
> The windows port is very much a work-in-progress. I'm not surprised
> that it doesn't work. :-\
>
> The good folks at U. Stuttgart/HLRS are actively working on a real
> Windows port, but it's off in a side-branch right now. I don't know
> the exact status of this port -- George / Rainer / Shiqing, can you
> comment?
>
>
> On Oct 22, 2008, at 9:54 AM, Gustavo Seabra wrote:
>
>> Hi All,
>>
>> (Sorry if you already got this message befor, but since I didn't get
>> any answer, I'm assuming it didn't get through to the list.)
>>
>> I am trying to install OpenMPI in Cygwin. from a cygwin bash shell, I
>> configured OpenMPI with the command below:
>>
>> $ echo $MPI_HOME
>> /home/seabra/local/openmpi-1.2.7
>> $ ./configure --prefix=$MPI_HOME \
>> --with-mpi-param_check=always \
>> --with-threads=posix \
>> --enable-mpi-threads \
>> --disable-io-romio \
>> FC="g95" FFLAGS="-O0 -fno-second-underscore" \
>> CXX="g++"
>>
>> The configuration *seems* to be OK (it finishes with: "configure:
>> exit
>> 0"). However, when I try to install it, the installation finishes
>> with
>> the error below. I wonder if anyone here could help me figure out
>> what
>> is going wrong.
>>
>> Thanks a lot!
>> Gustavo.
>>
>> ==============================
>> $ make clean
>> [...]
>> $ make install
>> [...]
>> Making install in mca/timer/windows
>> make[2]: Entering directory
>> `/home/seabra/local/openmpi-1.2.7/opal/mca/timer/windows'
>> depbase=`echo timer_windows_component.lo | sed 's|[^/]*$|.deps/&|;s|
>> \.lo$||'`;\
>> /bin/sh ../../../../libtool --tag=CC --mode=compile gcc
>> -DHAVE_CONFIG_H -I. -I../../../../opal/include
>> -I../../../../orte/include -I../../../../ompi/include -I../../../..
>> -D_REENTRANT -O3 -DNDEBUG -finline-functions -fno-strict-aliasing
>> -MT timer_windows_component.lo -MD -MP -MF $depbase.Tpo -c -o
>> timer_windows_component.lo timer_windows_component.c &&\
>> mv -f $depbase.Tpo $depbase.Plo
>> libtool: compile: gcc -DHAVE_CONFIG_H -I. -I../../../../opal/include
>> -I../../../../orte/include -I../../../../ompi/include -I../../../..
>> -D_REENTRANT -O3 -DNDEBUG -finline-functions -fno-strict-aliasing -MT
>> timer_windows_component.lo -MD -MP -MF
>> .deps/timer_windows_component.Tpo -c timer_windows_component.c
>> -DDLL_EXPORT -DPIC -o .libs/timer_windows_component.o
>> timer_windows_component.c:22:60:
>> opal/mca/timer/windows/timer_windows_component.h: No such file or
>> directory
>> timer_windows_component.c:25: error: parse error before
>> "opal_timer_windows_freq"
>> timer_windows_component.c:25: warning: data definition has no type or
>> storage class
>> timer_windows_component.c:26: error: parse error before
>> "opal_timer_windows_start"
>> timer_windows_component.c:26: warning: data definition has no type or
>> storage class
>> timer_windows_component.c: In function `opal_timer_windows_open':
>> timer_windows_component.c:60: error: `LARGE_INTEGER' undeclared
>> (first
>> use in this function)
>> timer_windows_component.c:60: error: (Each undeclared identifier is
>> reported only once
>> timer_windows_component.c:60: error: for each function it appears
>> in.)
>> timer_windows_component.c:60: error: parse error before "now"
>> timer_windows_component.c:62: error: `now' undeclared (first use in
>> this function)
>> make[2]: *** [timer_windows_component.lo] Error 1
>> make[2]: Leaving directory
>> `/home/seabra/local/openmpi-1.2.7/opal/mca/timer/windows'
>> make[1]: *** [install-recursive] Error 1
>> make[1]: Leaving directory `/home/seabra/local/openmpi-1.2.7/opal'
>> make: *** [install-recursive] Error 1
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
> --
> Jeff Squyres
> Cisco Systems
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users



  • application/pkcs7-signature attachment: smime.p7s