Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Question about openmpi and msc nastran
From: Joe Griffin (joe.griffin_at_[hidden])
Date: 2008-10-21 09:50:21


Pedro,

 

Please send me the first 60 lines of an F06 file ( for a serial run ).
I need to know

the specific version you have.

 

Can you also please send me the output from "ls -l
/msc/nastran/msc2007/linux864"

 

Also, you might want to e-mail me directly, since this issue is more
application

dependent than OpenMPI dependent.

 

Thanks,

Joe Griffin

joe.griffin_at_[hidden]

(714) 445-5636

 

 

 

 

________________________________

From: users-bounces_at_[hidden] [mailto:users-bounces_at_[hidden]] On
Behalf Of Pedro G
Sent: Tuesday, October 21, 2008 1:27 AM
To: Open MPI Users
Subject: Re: [OMPI users] Question about openmpi and msc nastran

 

I tried that configuration but I got a nastran error. It seems it hasn't
got an analyzer for open proc.

 

  a.solver=/msc/nastran/msc2007/linux8664/analysis.dmp.open
    This file does not exist.

How can I get it?
 

On 10/20/08, Joe Griffin <joe.griffin_at_[hidden]> wrote:

Pedro,

 

If you used "openmpi=yes" then you will also need to specify
"proc=open". I believe that was

the specification in 2007.0.3.

 

Regards,

Joe

 

 

 

 

________________________________

From: users-bounces_at_[hidden] [mailto:users-bounces_at_[hidden]] On
Behalf Of Pedro G
Sent: Monday, October 20, 2008 5:18 AM
To: Open MPI Users
Subject: Re: [OMPI users] Question about openmpi and msc nastran

 

 

On 10/20/08, Reuti <reuti_at_[hidden]> wrote:

Hi,

Am 20.10.2008 um 12:18 schrieb Pedro G:

I would like to know if Msc Nastran supports openmpi.

I have been searching in google about Nastran and Openmpi but I couldn't
find if it works or not.

Now I'm using lam/mpi for nastran parallel jobs, but I have some
problems with lam, nastran and sge, so I'd like to upgrade to openmpi.

do you have the source code of the application? If you have only the
binary compiled for LAM, then you can't do anything to change. You
checked the LAM/MPI Howto at the SGE website?

 

No, I don't have the source code, the application seems to be able to
work with openmpi since it has an option openmpi=yes in the command
line, but I couldn't make it to work. Anyway, I think it is not fully
supported yet since there is nothing about that option in the user
manual

 

About LAM/MPI I have already read the howto and did a tight integration.
The problem is that Msc Nastran in parallel jobs start a new lam
environment getting out of control of sge.

 

I contacted with Nastran and they told that was a LAM/MPI or SGE
problem.

 

 

 

         

        -- Reuti
        _______________________________________________
        users mailing list
        users_at_[hidden]
        http://www.open-mpi.org/mailman/listinfo.cgi/users

 

_______________________________________________
users mailing list
users_at_[hidden]
http://www.open-mpi.org/mailman/listinfo.cgi/users