Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Problems with OpenMPI running with Rmpi
From: Simone Giannerini (sgiannerini_at_[hidden])
Date: 2008-10-20 11:41:34


Dear Dirk,

many thanks for your reply,

>On 17 October 2008 at 12:42, Simone Giannerini wrote:
>| Dear all,
>|
>| I managed to install successfully Rmpi 0.5-5 on a quad opteron machine (8
>| cores overall) running on OpenSUSE 11.0 and Open MPI 1.5.2.
>|
>| this is what I get
>|
>| > library(Rmpi)
>| [gauss:24207] mca: base: component_find: unable to open osc pt2pt: file not
>| found (ignored)
>| libibverbs: Fatal: couldn't read uverbs ABI version.
>| --------------------------------------------------------------------------
>| [0,0,0]: OpenIB on host gauss was unable to find any HCAs.
>| Another transport will be used instead, although this may result in
>| lower performance.
>| --------------------------------------------------------------------------
>
>I am surprised that your googling did lead to you stumbling on dozens of
>posts on this telling you that the config file
>
> /etc/openmpi/openmpi-mca-params.conf (location for Debian etc)
>
>can be changed to explicitly setting btl to 'no openib' as in
>
> # Disable the use of InfiniBand
> # btl = ^openib
> btl = ^openib
>

thanks, I had also read some of your previous posts but for sure I
should have tried harder.

>which will suppress the warning by suppressing the load of IB. Better still,
>newer Open MPI release do this by default.
>

I managed to upgrade to version 1.2.6 that has that option enabled by default.
Unfortunately though, it only suppresses the following warning

libibverbs: Fatal: couldn't read uverbs ABI version.

while the others remain.
In any case as I pointed out in my previous post the issue is that
only two threads are spawn per session.
Maybe I should try to check whether Ompi is working properly before
getting to Rmpi.
I will try to work it out, of course any suggestions would be heartily welcome.

ciao

Simone

>| I have searched the archives and found that the following suggestion was
>| given for a similar problem:
>|
>| > Open MPI has Infiniband module compiled but there is no IB device found
>| > on your host. Try to add "--mca btl ^openib" string to your command
>| > line.
>
>That's one way of suppressing it, but not the only one.
>
>| Since I am not calling mpi directly but through Rmpi I do not know where to
>| put that flag, I might contact the Rmpi mantainer, in any case, I would be
>| grateful if you had further suggestions.
>
>There is nothing Rmpi can do there so contacting Dr Yu, while generally a
>good idea with actual Rmpi issues, is not really advised here.
>
>Cheers, Dirk

-- 
______________________________________________________
Simone Giannerini
Dipartimento di Scienze Statistiche "Paolo Fortunati"
Universita' di Bologna
Via delle belle arti 41 - 40126  Bologna,  ITALY
Tel: +39 051 2098262  Fax: +39 051 232153
http://www2.stat.unibo.it/giannerini/
______________________________________________________